Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#1011 closed enhancement (fixed)

Select multiple alternatives for a filter with a specified list of options

Reported by: Nicklas Nordborg Owned by: Nicklas Nordborg
Priority: minor Milestone: BASE 2.7
Component: web Version:
Keywords: Cc:

Description

This ticket replaces #962 and #964.

A property of an item that can have only a few distinct values are usually displayed as a dropdown list that includes all possible options by the filtering system in the web client. For example the status of a job has Waiting, Executing, Done, Error and a few other options. The drawback with this system is that it is only possible to filter on ONE value at a time. This was previously the case for all filters but #762 solved this for regular text input filters and #965 for enumerated annotations.

It should be possible to select more than one option in the list of options. It should be possible to specify if the filter should include or exclude all items that matches the selected options.

To implement this the <select> tag can't be used. It has a "multiple" attribute that in principle would solve the issue, but the list don't display well and they are hard to use. We probably need to use some fancy scripting similar to the annotations case.

Change History (5)

comment:1 Changed 14 years ago by Nicklas Nordborg

Status: newassigned

comment:2 Changed 14 years ago by Nicklas Nordborg

(In [4275]) References #1011: Allow to select multiple alternatives for a filter with a specified list of options

The functionality has now been implemented and enabled in the "View -> Formulas" list. Need to check all other places where an enumeration is used in a filter that it works, and add a "null" option if it is needed.

comment:3 Changed 14 years ago by Nicklas Nordborg

Summary: Allow to select multiple alternatives for a filter with a specified list of optionsSelect multiple alternatives for a filter with a specified list of options

comment:4 Changed 14 years ago by Nicklas Nordborg

Resolution: fixed
Status: assignedclosed

(In [4278]) Fixes #1011: Select multiple alternatives for a filter with a specified list of options

comment:5 Changed 14 years ago by Nicklas Nordborg

(In [4290]) References #1011: Select multiple alternatives for a filter with a specified list of options

Fixes an IE race condition that causes page loading to fail with the error message "Internet Explorer cannot open the Internet site....Operation aborted" on some pages. Adding defer="defer" to the <script> tag fixes the problem, which I think is caused by the call to document.body.appendChild(div); is being executed before the entire document has been loaded. The strange thing is that most pages always work, and some always fails. Adding the defer attribute seems to make all pages work.

Note: See TracTickets for help on using tickets.