Opened 16 years ago

Closed 15 years ago

#622 closed defect (fixed)

After restarting a job that has crashed an 'Item already exists' error is produced

Reported by: base Owned by: Johan Enell
Priority: major Milestone: BASE 2.4
Component: coreplugins Version:
Keywords: Cc:

Description

Hi,

I receive an 'Item already exists' error when restarting a failed job. The error message is displayed below:

Subject  	Error: Run plugin: Base1PluginExecuter
From 	SYSTEM
Time sent 	2007-05-31 09:26:42
Message 	Item already exists: Directory[id=161; name=146]

It seems that the creation of a directory fails because it already exists.

The stack trace:

net.sf.basedb.core.ItemAlreadyExistsException: Item already exists: Directory[id=161; name=146]
at net.sf.basedb.core.DbControl.saveItem(DbControl.java:819)
at net.sf.basedb.plugins.Base1PluginExecuter.createPluginDirectory(Base1PluginExecuter.java:372)
at net.sf.basedb.plugins.Base1PluginExecuter.run(Base1PluginExecuter.java:434)
at net.sf.basedb.core.PluginExecutionRequest.invoke(PluginExecutionRequest.java:88)
at net.sf.basedb.core.InternalJobQueue$JobRunner.run(InternalJobQueue.java:420)
at java.lang.Thread.run(Thread.java:595)

Details about the server:

Version  	BASE 2.2.3 (build #3253; schema #30)
Web server 	Apache Tomcat/5.5.20
Database Dialect 	org.hibernate.dialect.MySQLInnoDBDialect
JDBC Driver 	com.mysql.jdbc.Driver (version 5.0)
Java runtime 	Java(TM) 2 Runtime Environment, Standard Edition (1.5.0_08-b03), Sun Microsystems Inc.
Operating system 	SunOS sparc 5.10

/Robin

Change History (5)

comment:1 Changed 16 years ago by Jari Häkkinen

Milestone: BASE 2.3.1

comment:2 Changed 16 years ago by Johan Enell

Status: newassigned

comment:3 Changed 16 years ago by Johan Enell

Resolution: fixed
Status: assignedclosed

(In [3469]) Fixes #606 Fixes #622

comment:4 Changed 15 years ago by Nicklas Nordborg

Milestone: BASE 2.3.1BASE 2.4
Resolution: fixed
Status: closedreopened

The problem is not fixed:

net.sf.basedb.core.ItemAlreadyExistsException: Item already exists: Directory[id=38; name=15]
at net.sf.basedb.core.DbControl.saveItem(DbControl.java:819)
at net.sf.basedb.plugins.Base1PluginExecuter.createPluginDirectory(Base1PluginExecuter.java:478)
at net.sf.basedb.plugins.Base1PluginExecuter.getPluginDirectory(Base1PluginExecuter.java:1230)
at net.sf.basedb.plugins.Base1PluginExecuter.exportData(Base1PluginExecuter.java:722)
at net.sf.basedb.plugins.Base1PluginExecuter.run(Base1PluginExecuter.java:614)
at net.sf.basedb.core.PluginExecutionRequest.invoke(PluginExecutionRequest.java:88)
at net.sf.basedb.core.InternalJobQueue$JobRunner.run(InternalJobQueue.java:420)
at java.lang.Thread.run(Thread.java:619)

comment:5 Changed 15 years ago by Nicklas Nordborg

Resolution: fixed
Status: reopenedclosed

(In [3505]) Fixes #632, #622, #643, #644, #645, #646, #647

Note: See TracTickets for help on using tickets.