Opened 15 years ago

Closed 15 years ago

#468 closed defect (invalid)

File upload fails

Reported by: base Owned by: Nicklas Nordborg
Priority: trivial Milestone:
Component: core Version: 2.0
Keywords: file upload Cc:

Description

When I upload a file with user Root, I get:

Base version 2.0 (build #2807; schema #12) Web server Apache Tomcat/5.5 Database Dialect org.hibernate.dialect.MySQLInnoDBDialect JDBC Driver com.mysql.jdbc.Driver (version 3.1) Java runtime Java(TM) 2 Runtime Environment, Standard Edition (1.5.0_09-b03), Sun Microsystems Inc. Operating system Linux i386 2.6.18.1-miro-grs-ipv4-32 Memory Total: 61.9 MB Free: 24.10 MB Max: 63.6 MB Browser Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1) Error message File creation in base.config[userfiles] failed Stack trace

...at File.getNewFile(File.java:865) ...at File.getUploadStream(File.java:751) ...at org.apache.jsp.filemanager.upload.upload_jsp._jspService(upload_jsp.java:132) ...at org.apache.jasper.runtime.HttpJspBase?.service(HttpJspBase?.java:97) ...at javax.servlet.http.HttpServlet?.service(HttpServlet?.java:802) ...at org.apache.jasper.servlet.JspServletWrapper?.service(JspServletWrapper?.java:334) ...at org.apache.jasper.servlet.JspServlet?.serviceJspFile(JspServlet?.java:314) ...at org.apache.jasper.servlet.JspServlet?.service(JspServlet?.java:264) ...at javax.servlet.http.HttpServlet?.service(HttpServlet?.java:802) ...at org.apache.catalina.core.ApplicationFilterChain?.internalDoFilter(ApplicationFilterChain?.java:252) ...at org.apache.catalina.core.ApplicationFilterChain?.doFilter(ApplicationFilterChain?.java:173) ...at net.sf.basedb.clients.web.servlet.CharacterEncodingFilter?.doFilter(CharacterEncodingFilter?.java:71) ...at org.apache.catalina.core.ApplicationFilterChain?.internalDoFilter(ApplicationFilterChain?.java:202) ...at org.apache.catalina.core.ApplicationFilterChain?.doFilter(ApplicationFilterChain?.java:173) ...at org.apache.catalina.core.StandardWrapperValve?.invoke(StandardWrapperValve?.java:213) ...at org.apache.catalina.core.StandardContextValve?.invoke(StandardContextValve?.java:178) ...at org.apache.catalina.core.StandardHostValve?.invoke(StandardHostValve?.java:126) ...at org.apache.catalina.valves.ErrorReportValve?.invoke(ErrorReportValve?.java:105) ...at org.apache.catalina.core.StandardEngineValve?.invoke(StandardEngineValve?.java:107) ...at org.apache.catalina.connector.CoyoteAdapter?.service(CoyoteAdapter?.java:148) ...at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:869) ...at org.apache.coyote.http11.Http11BaseProtocol$Http11ConnectionHandler.processConnection(Http11BaseProtocol.java:664) ...at org.apache.tomcat.util.net.PoolTcpEndpoint?.processSocket(PoolTcpEndpoint?.java:527) ...at org.apache.tomcat.util.net.LeaderFollowerWorkerThread?.runIt(LeaderFollowerWorkerThread?.java:80) ...at org.apache.tomcat.util.threads.ThreadPool?$ControlRunnable?.run(ThreadPool?.java:684) ...at java.lang.Thread.run(Thread.java:595)

Caused by: java.io.IOException ...at java.io.UnixFileSystem?.createFileExclusively(Native Method) ...at java.io.File.createNewFile(File.java:850) ...at File.getNewFile(File.java:861) ...at File.getUploadStream(File.java:751) ...at org.apache.jsp.filemanager.upload.upload_jsp._jspService(upload_jsp.java:132) ...at org.apache.jasper.runtime.HttpJspBase?.service(HttpJspBase?.java:97) ...at javax.servlet.http.HttpServlet?.service(HttpServlet?.java:802) ...at org.apache.jasper.servlet.JspServletWrapper?.service(JspServletWrapper?.java:334) ...at org.apache.jasper.servlet.JspServlet?.serviceJspFile(JspServlet?.java:314) ...at org.apache.jasper.servlet.JspServlet?.service(JspServlet?.java:264) ...at javax.servlet.http.HttpServlet?.service(HttpServlet?.java:802) ...at org.apache.catalina.core.ApplicationFilterChain?.internalDoFilter(ApplicationFilterChain?.java:252) ...at org.apache.catalina.core.ApplicationFilterChain?.doFilter(ApplicationFilterChain?.java:173) ...at net.sf.basedb.clients.web.servlet.CharacterEncodingFilter?.doFilter(CharacterEncodingFilter?.java:71) ...at org.apache.catalina.core.ApplicationFilterChain?.internalDoFilter(ApplicationFilterChain?.java:202) ...at org.apache.catalina.core.ApplicationFilterChain?.doFilter(ApplicationFilterChain?.java:173) ...at org.apache.catalina.core.StandardWrapperValve?.invoke(StandardWrapperValve?.java:213) ...at org.apache.catalina.core.StandardContextValve?.invoke(StandardContextValve?.java:178) ...at org.apache.catalina.core.StandardHostValve?.invoke(StandardHostValve?.java:126) ...at org.apache.catalina.valves.ErrorReportValve?.invoke(ErrorReportValve?.java:105) ...at org.apache.catalina.core.StandardEngineValve?.invoke(StandardEngineValve?.java:107) ...at org.apache.catalina.connector.CoyoteAdapter?.service(CoyoteAdapter?.java:148) ...at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:869) ...at org.apache.coyote.http11.Http11BaseProtocol$Http11ConnectionHandler.processConnection(Http11BaseProtocol.java:664) ...at org.apache.tomcat.util.net.PoolTcpEndpoint?.processSocket(PoolTcpEndpoint?.java:527) ...at org.apache.tomcat.util.net.LeaderFollowerWorkerThread?.runIt(LeaderFollowerWorkerThread?.java:80) ...at org.apache.tomcat.util.threads.ThreadPool?$ControlRunnable?.run(ThreadPool?.java:684) ...at java.lang.Thread.run(Thread.java:595)

28 more...

Change History (1)

comment:1 Changed 15 years ago by Nicklas Nordborg

Priority: criticaltrivial
Resolution: invalid
Status: newclosed

Either the directory for uploaded file you have configured in your base.config doesn't exist or it isnot writeable by the user Tomcat is running as.

Note: See TracTickets for help on using tickets.