Opened 15 years ago

Closed 15 years ago

#379 closed defect (duplicate)

BASE2: Fails to display Raw data from a RawBioassay imported from BASE1.2.17

Reported by: simon.foote@… Owned by: Nicklas Nordborg
Priority: trivial Milestone:
Component: core Version: 2.0
Keywords: Cc:

Description

I've done a migration from 1.2.17 to base 2.0. No glaring errors were evident. But, when I pull up a RawBioassay? and try to view the data it gives a blank screen. The error logs show: java.lang.NoSuchMethodError?: net.sf.basedb.core.data.RawBioAssayData?.getHibernateLazyInitializer()Lorg/hibernate/proxy/LazyInitializer;

at net.sf.basedb.core.data.RawBioAssayData?$$EnhancerByCGLIB$$3631a698.getHibernateLazyInitializer(<generated>) at org.hibernate.type.EntityType?.resolveIdentifier(EntityType?.java:274) at org.hibernate.type.EntityType?.resolve(EntityType?.java:303)...

The blank screen appears to be caused by this message: org.apache.catalina.core.StandardHostValve?@ca328f: Exception Processing ErrorPage?[exceptionType=java.lang.Throwable, location=/exception/exception.jsp] java.lang.IllegalStateException?

at org.apache.coyote.Response.reset(Response.java:296) at org.apache.coyote.tomcat5.CoyoteResponse?.reset(CoyoteResponse?.java:646) at org.apache.coyote.tomcat5.CoyoteResponse?.reset(CoyoteResponse?.java:912)

...

Can anyone shed some light on this one.

Thanks, Simon

Change History (1)

comment:1 Changed 15 years ago by Nicklas Nordborg

Priority: criticaltrivial
Resolution: duplicate
Status: newclosed

This is a duplicate of ticket #99. A workaround is described in the installation documentation, section "viii. Tomcat".

Note: See TracTickets for help on using tickets.