Opened 15 years ago

Closed 15 years ago

#377 closed defect (worksforme)

hasData() flag not set on creation of new RawBioAssay, prevents Experiment creation

Reported by: micha.bayer@… Owned by: Nicklas Nordborg
Priority: major Milestone: BASE 2.0.2
Component: core Version: 2.0
Keywords: hasData, RawBioAssay Cc:

Description

When a new RawBioAssay? has been created and data have been imported into it, the "Has Data" property on the web client shows as false when it should be showing true, and in the database itself this property is not set at all. This prevents new Experiments from being created that use this RawBioAssay?.

Change History (6)

comment:1 Changed 15 years ago by Nicklas Nordborg

I am not able to reproduce this. Please provide more information about how to reproduce this error.

comment:2 Changed 15 years ago by micha.bayer@…

Here is how to reproduce the error:

  1. create new raw bioassay item (from web client)
  2. click import, then next
  3. select raw data file in dialog box and upload it
  4. Job shows as in progress and finishes normally
  5. exit raw bioassy item page and go back to it
  6. the Raw data tab shows the imported data but on the Properties tab, "Has data" is set to "no"
  7. go to view -> experiments and create new experiment
  8. click "Add raw bioassays..." , select appropriate data type and select the raw bioassay just created, then click ok
  9. in the Create Experiment View click "save"
  10. the following message appears:

Invalid data On page /base2/views/experiments/index.jsp No raw data has been added to the raw bioassay: Raw bioassay[id=5; name=testassay3]

  1. clicking close shuts the dialogue and new experiment has not been created

I have checked the actual back end database and there is no value entered for the has_data field for this record. If you manually update the field there and set the value of has_data to 1 then it shows as yes on the appropriate page in the web client, and you can then proceed to create an experiment.

comment:3 Changed 15 years ago by Nicklas Nordborg

This is more or less exactly the same steps I used to test it. But in my case the "Has data" is set to true at the end of the import. What is the message from the importer? It should hava a message about the number of spots that was inserted, for example: "Done: 36232 spots inserted".

comment:4 Changed 15 years ago by micha.bayer@…

Yes, I get the same message:

Done: 10263 spots inserted

I can also see the raw data attached to the raw bioassay, but it still thinks it has no data.

comment:5 Changed 15 years ago by micha.bayer@…

I have since tried this out on a different install of BASE2 which uses the full release 2.0 code and there the problem doesn't materialize.

The bug I initally reported relates to an install of RC2 so I assume the code has changed between releases and this is no longer an issue. You can probably close this ticket therefore -- apologies for any inconvenience caused.

comment:6 Changed 15 years ago by Nicklas Nordborg

Resolution: worksforme
Status: newclosed
Note: See TracTickets for help on using tickets.