Opened 16 years ago

Closed 16 years ago

#25 closed defect (fixed)

Changing information on how to get an account does not propagete to login screen

Reported by: Jari Häkkinen Owned by: Nicklas Nordborg
Priority: minor Milestone: BASE 2.0 RC2
Component: web Version:
Keywords: Cc:

Description (last modified by Jari Häkkinen)

Read this tickets short summary. Do the change, logout, try to click the "Get an account!" link. The same goes for "Forgot password" message.

Change History (4)

comment:1 Changed 16 years ago by Jari Häkkinen

Description: modified (diff)

comment:2 Changed 16 years ago by Nicklas Nordborg

Owner: changed from Gregory Vincic to Nicklas Nordborg
Status: newassigned

The cause of this behaviour is that those settings are loaded into the SessionControl? directly when the user hits the first page (ie. the login screen). The session is not discarded until the user leaves the BASE site. There are three possible solutions to the problem:

1) Provide functionality for reloading settings in the SessionControl? and use it as soon as the settings have been modified 2) Discard the SessionControl? when logging out

Solution 1) is probably better since it also works with settings that are used inside BASE. 2) would require a user to log out and then log in again in order to get the new settings.

comment:3 Changed 16 years ago by Nicklas Nordborg

Milestone: BASE 2.0 RC2

comment:4 Changed 16 years ago by Nicklas Nordborg

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.