Opened 6 years ago

Closed 6 years ago

#2008 closed defect (fixed)

It is not possible to change quota values

Reported by: Nicklas Nordborg Owned by: Nicklas Nordborg
Priority: major Milestone: BASE 3.9
Component: core Version:
Keywords: Cc:

Description

It is not possible to modify the quota values of existing quota entries. There is no error message. The quota value remains the same.

When creating new quota items there is a "side-effect" that always set the total quota to 0. This happens because the value is initialized to 0 and then it is not possible to change it.

Change History (3)

comment:1 Changed 6 years ago by Nicklas Nordborg

I think this was broken by #1742. The change near http://base.thep.lu.se/changeset/6468#file40 replaced a put() call with add(). The problem is that add() will not replace the existing value.

comment:2 Changed 6 years ago by Nicklas Nordborg

Milestone: BASE 3.8.1BASE 3.9
Owner: changed from everyone to Nicklas Nordborg
Status: newassigned

comment:3 Changed 6 years ago by Nicklas Nordborg

Resolution: fixed
Status: assignedclosed

(In [7155]) Fixes #2008: It is not possible to change quota values

Note: See TracTickets for help on using tickets.