Opened 9 years ago

Closed 9 years ago

#1706 closed defect (fixed)

External program executor and BASE 1 plug-in executor doesn't remove temporary working files

Reported by: Nicklas Nordborg Owned by: everyone
Priority: minor Milestone: BASE 3.2
Component: coreplugins Version:
Keywords: Cc:

Description

This can be seen when running the TestAll program. After the test, the temporary folder contain subfolders like executor-20120803-101035-4643874462231498128.tmp and base1executor-20120803-101035-3152960075585150415.tmp which contain exported and analyzed data.

Both plug-ins try to delete the temporary files, but fails to do so in some cases. The external program executor seems to be better since it only leave BASEfile:s behind. When the external program executor is used with the BFS file format everything seems to get correctly cleaned up.

My guess is that the problem lies with the BASEfile exporter code. It could, for example, be caused by not properly closing the output files.

Change History (1)

comment:1 Changed 9 years ago by Nicklas Nordborg

Resolution: fixed
Status: newclosed

(In [6077]) Fixes #1706: External program executor and BASE 1 plug-in executor doesn't remove temporary working files

Note: See TracTickets for help on using tickets.