Opened 10 years ago

Closed 10 years ago

#1705 closed enhancement (fixed)

Add support for pausing and resuming file downloads

Reported by: Nicklas Nordborg Owned by: Nicklas Nordborg
Priority: minor Milestone: BASE 3.2
Component: web Version:
Keywords: Cc:

Description (last modified by Nicklas Nordborg)

Firefox (and Internet Explorer 9) has a feature when downloading files that allows a user to pause a download and then resume it later. However, this feature doesn't work when downloading files from BASE. Firefox displays an error:

<filename> could not be saved, because the source file could not be read.

Try again later, or contact the server administrator.

The main reason behind the problem is that when resuming, Firefox submits a second download request to BASE that includes a "Range" header that include information about how much of the file that has already been downloaded.

When using IE 9 the "Pause" button is disabled. An additional "ETag" header is need in the response to enable the functionality. See http://blogs.msdn.com/b/ieinternals/archive/2011/06/03/send-an-etag-to-enable-http-206-file-download-resume-without-restarting.aspx

Change History (3)

comment:1 Changed 10 years ago by Nicklas Nordborg

Description: modified (diff)
Owner: changed from everyone to Nicklas Nordborg
Status: newassigned
Summary: Add support for resuming downloads with FirefoxAdd support for resuming file downloads

comment:2 Changed 10 years ago by Nicklas Nordborg

Description: modified (diff)
Summary: Add support for resuming file downloadsAdd support for pausing and resuming file downloads

comment:3 Changed 10 years ago by Nicklas Nordborg

Resolution: fixed
Status: assignedclosed

(In [6071]) Fixes #1705: Add support for pausing and resuming file downloads

Note: See TracTickets for help on using tickets.