Opened 12 years ago

Closed 12 years ago

#1505 closed defect (fixed)

Table exporter fails with NPE when exporting spot data

Reported by: Jari Häkkinen Owned by: Nicklas Nordborg
Priority: major Milestone: BASE 2.16
Component: coreplugins Version: 2.15
Keywords: Cc:

Description

I am trying to export spot data from a table listing. Clicking on the 'Export...' button and selecting all columns and immediate download simply displays 0% with no progress. Trying to perform the same export but to a file gives the below stack trace. Status message is simply 'Error:'

java.lang.NullPointerExceptioning
at java.lang.Class.isAssignableFrom(Native Method)
at net.sf.basedb.core.Metadata.getInstance(Metadata.java:223)
at net.sf.basedb.clients.web.plugins.SimpleExport.performExport(SimpleExport.java:274)
at net.sf.basedb.core.plugin.AbstractExporterPlugin.run(AbstractExporterPlugin.java:144)
at net.sf.basedb.core.PluginExecutionRequest.invoke(PluginExecutionRequest.java:110)
at net.sf.basedb.core.PluginExecutionRequest.run(PluginExecutionRequest.java:135)
at java.lang.Thread.run(Thread.java:637)

My configuration is

Version  	BASE 2.15.0pre (build #5300; schema #79)
Web server 	Apache Tomcat/6.0.16
Database Server 	MySQL 5.1.48
Database Dialect 	org.hibernate.dialect.MySQLInnoDBDialect
JDBC Driver 	com.mysql.jdbc.Driver (version 5.1)
Java runtime 	Java(TM) SE Runtime Environment (1.6.0_20-b02-279-10M3065), Apple Inc.
Operating system 	Mac OS X x86_64 10.6.4
Memory 	Total: 141.9 MB
Free: 7.1 MB
Max: 910.3 MB

Change History (4)

comment:1 Changed 12 years ago by Nicklas Nordborg

Milestone: BASE 2.16

I can confirm this in the trunk. The error happens even if I only select a single column and it doesn't seem to matter which column.

comment:2 Changed 12 years ago by Nicklas Nordborg

Owner: changed from everyone to Nicklas Nordborg
Status: newassigned

This issue was probably caused by changes for ticket #1343 [5299].

comment:3 Changed 12 years ago by Nicklas Nordborg

Summary: Table exporter failsTable exporter fails with NPE when exporting spot data

comment:4 Changed 12 years ago by Nicklas Nordborg

Resolution: fixed
Status: assignedclosed

(In [5400]) Fixes #1505: Table exporter fails with NPE when exporting spot data

Note: See TracTickets for help on using tickets.