Opened 13 years ago

Closed 13 years ago

#1348 closed defect (duplicate)

Files shared to a project give ugly permission denied exception when changing project

Reported by: base Owned by: everyone
Priority: major Milestone:
Component: web Version: 2.11.1
Keywords: permission denied exception Cc:

Description

Hello,

We came across a very ugly exception linked to access problems. It is not harmful, but might be scary to some inexperienced users. Here is how to reproduce it:

1) as user U1 create a project P1 and add U2 as a member 2) share directory /Home/U1/any_dir to project P1 (as well as /Home and /Home/U1) 3) Log in as U2, activate project P1 and navigate to /Home/U1/any_dir 4) (optional) Go to View->Projects. This step is just to get to another webpage (can be anything in the menu, except Files) 5) deactivate P1 6) go to View->Files

Here BASE will try to get to location where you left file manager(/Home/U1/any_dir). Since the project has been deactivated you have no longer access to directory that had been shared to P1. This results in very bad looking permission denied exception in web client and prevents from using file manager normally unless user knows what has happened and which project should be activated again. In case when one has many projects and has left file manager some time ago (does not remember recent directory), it might not be straightforward.

Change History (2)

comment:1 Changed 13 years ago by base

Sorry for reporting this. I haven't noticed it's been solved in http://base.thep.lu.se/ticket/1306

comment:2 Changed 13 years ago by Jari Häkkinen

Resolution: duplicate
Status: newclosed
Version: 2.11.1
Note: See TracTickets for help on using tickets.