Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#1334 closed defect (fixed)

Unable to resolve property: $rba when exporting experimatal factors for bioassays

Reported by: Nicklas Nordborg Owned by: everyone
Priority: minor Milestone: BASE 2.12.1
Component: web Version:
Keywords: Cc:

Description

To reproduce this an experiment with at least one experimental factor and a root bioassay set is needed. Select the root bioassay set (or any other bioassay set) and then go to the "BioAssays?" tab. Change the column display to also include one or more experimental factors. Then, click on export and make sure that at least one experimental factor column [EF] is selected for export. The following error happens during the export (if download immediately is used the error message is in the downloaded file):

java.io.IOException: Unable to resolve property: $rba
	at net.sf.basedb.clients.web.plugins.SimpleExport.exportProperties(SimpleExport.java:610)
	at net.sf.basedb.clients.web.plugins.SimpleExport.performExport(SimpleExport.java:330)
	at net.sf.basedb.core.plugin.AbstractExporterPlugin.doExport(AbstractExporterPlugin.java:187)
	at net.sf.basedb.core.PluginResponse.downloadImmediately(PluginResponse.java:181)
	at org.apache.jsp.common.plugin.index_jsp._jspService(index_jsp.java:609)
	at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:70)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
	at org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:374)
	at org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:342)
	at org.apache.jasper.servlet.JspServlet.service(JspServlet.java:267)
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
	at net.sf.basedb.clients.web.servlet.CharacterEncodingFilter.doFilter(CharacterEncodingFilter.java:70)
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
	at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:233)
	at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:191)
	at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:128)
	at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
	at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
	at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:286)
	at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:845)
	at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:583)
	at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:447)
	at java.lang.Thread.run(Thread.java:619)
Caused by: net.sf.basedb.core.BaseException: Unable to resolve property: $rba
	at net.sf.basedb.core.Metadata.getPropertyValue(Metadata.java:367)
	at net.sf.basedb.clients.web.plugins.ItemQueryWrapper.getData(ItemQueryWrapper.java:82)
	at net.sf.basedb.clients.web.plugins.ItemQueryWrapper.getData(ItemQueryWrapper.java:38)
	at net.sf.basedb.clients.web.plugins.SimpleExport.exportProperties(SimpleExport.java:579)
	... 25 more
Caused by: org.hibernate.HibernateException: Unable to resolve property: $rba
	at org.hibernate.tuple.entity.EntityMetamodel.getPropertyIndex(EntityMetamodel.java:473)
	at org.hibernate.tuple.entity.AbstractEntityTuplizer.getPropertyValue(AbstractEntityTuplizer.java:309)
	at org.hibernate.persister.entity.AbstractEntityPersister.getPropertyValue(AbstractEntityPersister.java:3614)
	at net.sf.basedb.core.Metadata.getPropertyValue(Metadata.java:360)
	... 28 more

The cause of the problem is that the exporter doesn't support exporting experimental factors. The "fix" is to not select any experimental factor columns for export.

Change History (3)

comment:1 Changed 13 years ago by Nicklas Nordborg

Resolution: fixed
Status: newclosed

(In [4969]) Fixes #1334: Unable to resolve property: $rba when exporting experimatal factors for bioassays

comment:2 Changed 13 years ago by Nicklas Nordborg

(In [4970]) Fixes #1334: Unable to resolve property: $rba when exporting experimatal factors for bioassays

[4969] was in wrong branch.

comment:3 Changed 13 years ago by Nicklas Nordborg

Added #1335 to implement support for exporting experimental factors.

Note: See TracTickets for help on using tickets.