Opened 13 years ago

Closed 13 years ago

#1224 closed defect (invalid)

Running two "New root bioassay set" jobs at the same time makes the second to finish crash

Reported by: Jari Häkkinen Owned by: everyone
Priority: major Milestone:
Component: coreplugins Version: 2.9.1
Keywords: Cc:

Description

This is at least true or affymetrix. I wanted to create two new root bioassay sets by runnign two different plugins. The first to finish ended succesfully, the second finished with the below message. Nothing strange really but can it be avoided?

Error: Permission denied: The item RawBioAssay[id=14538] was modified by another transaction. 

net.sf.basedb.core.ItemModifiedException: Permission denied: The item RawBioAssay[id=14538] was modified by another transaction.
at net.sf.basedb.core.HibernateUtil.commit(HibernateUtil.java:1025)
at net.sf.basedb.core.DbControl.commit(DbControl.java:410)
at se.lu.thep.affymetrix.AbstractExternalBinaryPlugin.run(AbstractExternalBinaryPlugin.java:264)
at net.sf.basedb.core.PluginExecutionRequest.invoke(PluginExecutionRequest.java:106)
at net.sf.basedb.clients.jobagent.executors.ThreadJobExecutor.executeJob(ThreadJobExecutor.java:109)
at net.sf.basedb.clients.jobagent.executors.ThreadJobExecutor.main(ThreadJobExecutor.java:202)
Caused by: org.hibernate.StaleObjectStateException: Row was updated or deleted by another transaction (or unsaved-value mapping was incorrect): [net.sf.basedb.core.data.RawBioAssayData#14538]
at org.hibernate.persister.entity.AbstractEntityPersister.check(AbstractEntityPersister.java:1792)
at org.hibernate.persister.entity.AbstractEntityPersister.update(AbstractEntityPersister.java:2435)
at org.hibernate.persister.entity.AbstractEntityPersister.updateOrInsert(AbstractEntityPersister.java:2335)
at org.hibernate.persister.entity.AbstractEntityPersister.update(AbstractEntityPersister.java:2635)
at org.hibernate.action.EntityUpdateAction.execute(EntityUpdateAction.java:115)
at org.hibernate.engine.ActionQueue.execute(ActionQueue.java:279)
at org.hibernate.engine.ActionQueue.executeActions(ActionQueue.java:263)
at org.hibernate.engine.ActionQueue.executeActions(ActionQueue.java:168)
at org.hibernate.event.def.AbstractFlushingEventListener.performExecutions(AbstractFlushingEventListener.java:321)
at org.hibernate.event.def.DefaultFlushEventListener.onFlush(DefaultFlushEventListener.java:50)
at org.hibernate.impl.SessionImpl.flush(SessionImpl.java:1027)
at org.hibernate.impl.SessionImpl.managedFlush(SessionImpl.java:365)
at org.hibernate.transaction.JDBCTransaction.commit(JDBCTransaction.java:137)
at net.sf.basedb.core.HibernateUtil.commit(HibernateUtil.java:1016)
... 5 more

Change History (1)

comment:1 Changed 13 years ago by Nicklas Nordborg

Resolution: invalid
Status: newclosed

There is no problem when using the "Formula intensity calculator" plug-in so it may be that the problem lies with the Affymetrix plug-in and/or the other unknown plug-in. I have moved this ticket to http://baseplugins.thep.lu.se/ticket/169.

Note: See TracTickets for help on using tickets.