Opened 13 years ago

Closed 13 years ago

#1064 closed enhancement (fixed)

Add support for dry-run to the plug-in system

Reported by: Nicklas Nordborg Owned by: Nicklas Nordborg
Priority: major Milestone: BASE 2.8
Component: core Version:
Keywords: Cc:

Description (last modified by Nicklas Nordborg)

There is a wish in ticket #1028 that it should be possible to run a plug-in in dry-run mode. In principle it is not very complicated since the plug-in only has to skip the call to DbControl.commit() and no changes will be saved to the database.

The problem is what to do after the dry-run. If everything is ok, the user will probably want to run the plug-in again but without the dry-run flag. If there was a problem, the user wants to change the parameters. Neither of this is currently possible. The only workaround is to start with a new job with the same parameters (except for the dry-run flag). This kind of limits the usefulness of a dry-run flag since it is error-prone to have to enter the same parameters a second time.

The first case (everything is ok) can be solved by introducing a new return status for jobs: DONE_DRY_RUN. This could be used to trigger a "Run again" button in the GUI that runs the plug-in without the dry-run flag.

The second case is (failure) is more problematic and is covered in a separate ticket #1082.

Change History (4)

comment:1 Changed 13 years ago by Nicklas Nordborg

Milestone: BASE 2.8
Owner: changed from everyone to Nicklas Nordborg
Status: newassigned

The context information we need to re-configure a failed job is only three new fields: itemType, contextType and subcontext. If this information is stored together with the job it should be possible to re-configure it.

comment:2 Changed 13 years ago by Nicklas Nordborg

Description: modified (diff)

comment:3 Changed 13 years ago by Nicklas Nordborg

(In [4378]) References #1064, #1082, #1050, #1024, #967

Updated UML diagrams as a result of new db columns added by the referenced tickets.

comment:4 Changed 13 years ago by Nicklas Nordborg

Resolution: fixed
Status: assignedclosed

(In [4380]) Fixes #1064: Add support for dry-run to the plug-in system

Note: See TracTickets for help on using tickets.