Opened 14 years ago

Closed 13 years ago

#1028 closed task (fixed)

Plug-in for batch upload/modification of items

Reported by: Jari Häkkinen Owned by: Jari Häkkinen
Priority: blocker Milestone: BASE 2.8
Component: coreplugins Version: trunk
Keywords: Cc:

Description (last modified by Nicklas Nordborg)

References to the latest versions of files (please keep this list up to date):

Sample files:

  • Sample spreadsheet with comments (batchimport_sample.ods). The spreadsheet contains multiple sample sheets for use with the importer. Each item type to be supported has a separate sheet, the sheet content may have comments below the legend on this page. Currently the BASE internal 'id' is not used. Types to be done are Hybridization, Scan, RawBioassay, and Experiment.

Attachments (7)

batchimport.txt (11.9 KB) - added by Nicklas Nordborg 14 years ago.
First draft of a developers view
batchimport-2.txt (12.5 KB) - added by Jari Häkkinen 13 years ago.
batchimport_userperspective.txt (7.6 KB) - added by Jari Häkkinen 13 years ago.
First draft of a users view
batchimport_userperspective-2.txt (10.9 KB) - added by Jari Häkkinen 13 years ago.
batchimport_userperspective-3.txt (11.1 KB) - added by Jari Häkkinen 13 years ago.
batchimport-3.txt (12.1 KB) - added by Nicklas Nordborg 13 years ago.
3rd version of developers view
batchimport-4.txt (11.7 KB) - added by Nicklas Nordborg 13 years ago.
4th version of developers view

Download all attachments as: .zip

Change History (33)

comment:1 Changed 14 years ago by Jari Häkkinen

Status: newassigned

comment:2 Changed 14 years ago by Jari Häkkinen

Priority: majorblocker

Changed 14 years ago by Nicklas Nordborg

Attachment: batchimport.txt added

First draft of a developers view

Changed 13 years ago by Jari Häkkinen

Attachment: batchimport-2.txt added

comment:3 Changed 13 years ago by Jari Häkkinen

I have added a version 2 of the specification doc. There are a couple of comments, look for JH. I'll create sample docs matching the specs, and I am looking into the list of importable objects.

Changed 13 years ago by Jari Häkkinen

First draft of a users view

comment:4 Changed 13 years ago by Jari Häkkinen

Description: modified (diff)

comment:5 Changed 13 years ago by Jari Häkkinen

In the batchimport.txt document there is a discussion on multi-item references:

Data for a single item may be split onto multiple lines. The first
line contains simple properties and single-item references, and the
first multi-item reference. If there are more multi-item references
they should be on the following lines with empty values in all other
columns, except for the column holding the item identifier, which
must have the same value on all lines. If the following lines
contains other data, this should be ignored, or it may be considered
an error condition. It may be caused by giving two items the same
name by accident.

In the above text there is a reference to the item reference column. Maybe it is implied, but I think we should specifically state that this column is the same as used by single item references. In the openoffice sample document I have used the same column for simple and pooled samples (see Sample sheet in attached spreadsheet).

comment:6 Changed 13 years ago by Jari Häkkinen

I added a spreadsheet with sample sheets for use with the batch item importer.

comment:7 Changed 13 years ago by Jari Häkkinen

Description: modified (diff)

Changed 13 years ago by Jari Häkkinen

comment:8 Changed 13 years ago by Jari Häkkinen

Description: modified (diff)

batchimport_userperspective.txt updated.

comment:9 Changed 13 years ago by Jari Häkkinen

Description: modified (diff)

Updated spreadsheet, sample information to the labeled extracts step with pooling is available in the doc.

Changed 13 years ago by Jari Häkkinen

comment:10 Changed 13 years ago by Jari Häkkinen

Description: modified (diff)

Major revision of the user perspective, and the sample openoffice is now complete. All items that should be supported by the importer is discussed and described in the docs.

comment:11 Changed 13 years ago by Nicklas Nordborg

Summary: Write specification for batch upload/modificatin of itemsPlug-in for batch upload/modification of items

comment:12 Changed 13 years ago by Nicklas Nordborg

(In [4366]) References #1028: Plug-in for batch upload/modification of items

Prototype for biosurce and sample import added.

comment:13 Changed 13 years ago by Nicklas Nordborg

(In [4372]) References #1028: Plug-in for batch upload/modification of items

Added importers for extract and labeled extract.

Changed 13 years ago by Nicklas Nordborg

Attachment: batchimport-3.txt added

3rd version of developers view

comment:14 Changed 13 years ago by Nicklas Nordborg

Description: modified (diff)

comment:15 Changed 13 years ago by Nicklas Nordborg

(In [4408]) References #1028: Plug-in for batch upload/modification of items

Fixes a NPE when creating a configuration.

comment:16 Changed 13 years ago by Nicklas Nordborg

(In [4413]) References #1028: Plug-in for batch upload/modification of items

Made some parameter descriptions clearer.

comment:17 Changed 13 years ago by Nicklas Nordborg

(In [4414]) References #1028: Plug-in for batch upload/modification of items

No duplicate column mapping for item identification.

comment:18 Changed 13 years ago by Jari Häkkinen

Updated sample spreadsheet. Biosources, Samples, Extracts, Labeled extracs are tested with the batch importers.

comment:19 Changed 13 years ago by Nicklas Nordborg

(In [4423]) References #1028: Plug-in for batch upload/modification of items

Added "mode" parameter for selecting "create" and/or "update" mode. Reordered parameters on first wizard page.

comment:20 Changed 13 years ago by Nicklas Nordborg

(In [4426]) References #1028: Plug-in for batch upload/modification of items

Added:

comment:21 Changed 13 years ago by Jari Häkkinen

Description: modified (diff)

Updated the sample spreadsheet, now decimal point is used instead of decimal comma.

comment:22 Changed 13 years ago by Nicklas Nordborg

(In [4434]) References #1028 :Plug-in for batch upload/modification of items

Completed raw bioassay importer and added array design, batch and slide importers.

comment:23 Changed 13 years ago by Nicklas Nordborg

(In [4449]) References #1028: Plug-in for batch upload/modification of items

Do not offer "create" mode to users which lacks CREATE permission.

Changed 13 years ago by Nicklas Nordborg

Attachment: batchimport-4.txt added

4th version of developers view

comment:24 Changed 13 years ago by Nicklas Nordborg

Description: modified (diff)

comment:25 Changed 13 years ago by Nicklas Nordborg

(In [4451]) References #1028: Plug-in for batch upload/modification of items

Fixes a NPE when "File" column is empty.

comment:26 Changed 13 years ago by Nicklas Nordborg

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.