Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#1045 closed defect (fixed)

File list view creates an exception

Reported by: Jari Häkkinen Owned by: Nicklas Nordborg
Priority: major Milestone: BASE 2.8
Component: web Version: trunk
Keywords: Cc:

Description

When I try to view my files as ordinary user I get the below exception. File listings work as administrator.

Unexpected error
java.lang.NullPointerException on page /base2dev/filemanager/files/list_files.jsp
	
Version 	BASE 2.8.0pre (build #4311; schema #58)
Web server 	Apache Tomcat/6.0.16
Database Server 	MySQL 5.0.51
Database Dialect 	org.hibernate.dialect.MySQLInnoDBDialect
JDBC Driver 	com.mysql.jdbc.Driver (version 5.1)
Java runtime 	Java(TM) SE Runtime Environment (1.6.0_05-b13-120), Apple Inc.
Operating system 	Mac OS X x86_64 10.5.2
Memory 	Total: 897.9 MB
Free: 450.6 MB
Max: 981.4 MB
Browser 	Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.14) Gecko/20080404 Firefox/2.0.0.14
Error message 	
Stack trace 	

java.lang.NullPointerException
...at net.sf.basedb.clients.web.taglib.table.ColumnDef.doStartTag(ColumnDef.java:707)
...at org.apache.jsp.filemanager.files.list_005ffiles_jsp._jspService(list_005ffiles_jsp.java:767)
...at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:70)
...at javax.servlet.http.HttpServlet.service(HttpServlet.java:803)
...at org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:374)
...at org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:337)
...at org.apache.jasper.servlet.JspServlet.service(JspServlet.java:266)
...at javax.servlet.http.HttpServlet.service(HttpServlet.java:803)

...at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
...at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
...at net.sf.basedb.clients.web.servlet.CharacterEncodingFilter.doFilter(CharacterEncodingFilter.java:72)
...at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
...at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
...at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:233)
...at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:175)
...at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:128)
...at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
...at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
...at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:286)
...at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:844)
...at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:583)
...at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:447)
...at java.lang.Thread.run(Thread.java:637)

Attachments (1)

list_005ffiles_jsp.java (303.4 KB) - added by Jari Häkkinen 14 years ago.

Download all attachments as: .zip

Change History (5)

comment:1 Changed 14 years ago by Nicklas Nordborg

Most likely this doesn't have anything to do with which user is logged in. The code fails because there is a filter that has length > 0 but still is null... It seems a bit strange, but the code is checking two different variables. They SHOULD correlate, but obviously they don't.

So, do you have any more information about which filters are active when it fails?

This could be related to #1016 since the line were it fails was added as part of that ticket.

comment:2 Changed 14 years ago by Nicklas Nordborg

Owner: changed from everyone to Nicklas Nordborg
Status: newassigned

I have traced this to a possible problem for all enumerated columns that has the possibility of selecting a '-none-' value. The problem is not present in 2.7. It seems like it was introduced by [4302] when adding the "multiple" parameter to the the ColumnDef class.

comment:3 Changed 14 years ago by Nicklas Nordborg

Resolution: fixed
Status: assignedclosed

(In [4326]) Fixes #1045. References #1016.

comment:4 Changed 14 years ago by Jari Häkkinen

The ticket is closed but I added the list java file causing the trouble (taken from my tomcat work directory).

Changed 14 years ago by Jari Häkkinen

Attachment: list_005ffiles_jsp.java added
Note: See TracTickets for help on using tickets.