#2171 closed defect (fixed)

Exception when switching to the Annotations tab in the Edit project dialog

Reported by: Nicklas Nordborg Owned by: everyone
Priority: major Milestone: BASE 3.15
Component: web Version:
Keywords: Cc:

Description

HTTP Status 400 – Bad Request
java.lang.IllegalArgumentException: Invalid character found in the request target. 
The valid characters are defined in RFC 7230 and RFC 3986
	org.apache.coyote.http11.Http11InputBuffer.parseRequestLine(Http11InputBuffer.java:467)
	org.apache.coyote.http11.Http11Processor.service(Http11Processor.java:294)
	org.apache.coyote.AbstractProcessorLight.process(AbstractProcessorLight.java:66)
	org.apache.coyote.AbstractProtocol$ConnectionHandler.process(AbstractProtocol.java:834)
	org.apache.tomcat.util.net.NioEndpoint$SocketProcessor.doRun(NioEndpoint.java:1415)
	org.apache.tomcat.util.net.SocketProcessorBase.run(SocketProcessorBase.java:49)
	java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1128)
	java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:628)
	org.apache.tomcat.util.threads.TaskThread$WrappingRunnable.run(TaskThread.java:61)
	java.base/java.lang.Thread.run(Thread.java:834)

Checking the request URI, it ends with: &protocol_id=[object%20Event] and I assume that it is the square brackets that are the cause of the error. Further investigations show that the javascript method Annotations.autoLoadEditFrame() is attached as an event handler to the "Annotations" tab, but in the documentations it says: ...DO NOT USE AS AN EVENT HANDLER. It has been like this since BASE 3.6 (#1941) but I guess it has popped up now beacuse of differences between Tomcat 8 and 9.

Change History (1)

comment:1 Changed 23 months ago by Nicklas Nordborg

Resolution: fixed
Status: newclosed

In 7695:

Fixes #2171: Exception when switching to the Annotations tab in the Edit project dialog

Replaced Annotations.autoLoadEditFrame() with Annotations.onSwitchToAnnotationsTab().

Note: See TracTickets for help on using tickets.