Opened 4 weeks ago

Closed 8 days ago

#2116 closed defect (fixed)

The "Character set" of a file seems to be reverted to the default "ISO-8859-1" in some cases

Reported by: nicklas Owned by: everyone
Priority: minor Milestone: BASE 3.12.3
Component: web Version:
Keywords: Cc:

Description

I have not investigated this in detail yet, but using a batch importer and the "Test with file" function seems to reset the character set that is stored in the database in some cases. If the user fails to notice this the file will be parsed with the incorrect character set.

Change History (2)

comment:1 Changed 4 weeks ago by nicklas

It seems like the problem is related to the default state of the plug-in parameters dialog. I have seen that the default character set is then "ISO-8859-1" even if a file with a different character set is selected. As soon as the gui is used to browse for and select a file, the character set is updated to the correct one.

comment:2 Changed 8 days ago by nicklas

  • Resolution set to fixed
  • Status changed from new to closed

(In [7482]) Fixes #2116: The "Character set" of a file seems to be reverted to the default "ISO-8859-1" in some cases

The problem was that the last used file is auto-selected by the plug-in configuration but it didn't handle the case when the files character set is different than the default character set. This has been fixed by storing the character set in the current context under the key last-file-charset.

The same problem was also present when the auto-detect file format function was used.

Note: See TracTickets for help on using tickets.