Opened 6 years ago

Closed 5 years ago

Last modified 5 years ago

#1890 closed enhancement (fixed)

Improve skinnability of BASE

Reported by: Nicklas Nordborg Owned by: Nicklas Nordborg
Priority: major Milestone: BASE 3.4
Component: web Version:
Keywords: Cc:

Description (last modified by Nicklas Nordborg)

Ticket #1886 will add support for adding skins to BASE. Much of the skinning will probably be made through overriding CSS properties with new colors and backgrounds. The problem is that the current BASE CSS files are very repetitive. For example, it is almost impossible to change the two main background colors (white and gray) since they are coded into several places in the CSS.

Due to the "static" nature of CSS it will not be possible to get rid of all places, but I think the situation can be improved somewhat.

Side-note: The Mozilla team has implemented a new feature in Firefox that enables CSS to use defined variables. See https://developer.mozilla.org/en-US/docs/Web/CSS/Using_CSS_variables. This would be nice, since we could then define almost everything a single time, but it will probably take some time until this is implemented in IE also...

Change History (31)

comment:1 Changed 6 years ago by Nicklas Nordborg

Description: modified (diff)

comment:2 Changed 6 years ago by Nicklas Nordborg

Owner: changed from everyone to Nicklas Nordborg
Status: newassigned

comment:3 Changed 6 years ago by Nicklas Nordborg

(In [6603]) References #1890: Improve skinnability of BASE

Updated some basic elements:

  • buttons
  • toolbars
  • table listing
  • tabs part of tabcontrol

comment:4 Changed 6 years ago by Nicklas Nordborg

(In [6604]) References #1890: Improve skinnability of BASE

Updated table listings with some new css classes to make it easier to modify background color.

comment:5 Changed 6 years ago by Nicklas Nordborg

(In [6605]) References #1890: Improve skinnability of BASE

Updated regular view pages and edit dialogs.

comment:6 Changed 6 years ago by Nicklas Nordborg

(In [6606]) References #1890: Improve skinnability of BASE

Iframe:d pages.

comment:7 Changed 6 years ago by Nicklas Nordborg

(In [6607]) References #1890: Improve skinnability of BASE

Minor adjustmen to most of the common utility pages.

comment:8 Changed 6 years ago by Nicklas Nordborg

(In [6608]) References #1890: Improve skinnability of BASE

Introducing 'interactable' class to be used for items that we typically mark with a thicker border in a different color. Fixing special selection lists for enumeration options in table listing.

comment:9 Changed 6 years ago by Nicklas Nordborg

(In [6609]) References #1890: Improve skinnability of BASE

Fixed the menu system

comment:10 Changed 6 years ago by Nicklas Nordborg

(In [6610]) References #1890: Improve skinnability of BASE

Several minor changes in various places.

comment:11 Changed 6 years ago by Nicklas Nordborg

(In [6611]) References #1890: Improve skinnability of BASE

Bioplate wizards and data files selection.

comment:12 Changed 6 years ago by Nicklas Nordborg

(In [6612]) References #1890: Improve skinnability of BASE

Experiment explorer and plotter.

comment:13 Changed 6 years ago by Nicklas Nordborg

(In [6613]) References #1890: Improve skinnability of BASE

Minor adjustments.

comment:14 Changed 6 years ago by Nicklas Nordborg

(In [6614]) References #1890: Improve skinnability of BASE

Another joust fix.

comment:15 Changed 6 years ago by Nicklas Nordborg

(In [6615]) References #1890: Improve skinnability of BASE

Notification used when information is missing.

comment:16 Changed 6 years ago by Nicklas Nordborg

(In [6616]) References #1890: Improve skinnability of BASE

Adding more tags to navigator so that it should be possible to style different sections more easily.

comment:17 Changed 6 years ago by Nicklas Nordborg

(In [6617]) References #1890: Improve skinnability of BASE

Improved 'disabled' and 'selected' definitions.

comment:18 Changed 6 years ago by Nicklas Nordborg

(In [6618]) References #1890: Improve skinnability of BASE

Moved some definitions so they can be overridden as needed.

comment:19 Changed 6 years ago by Nicklas Nordborg

(In [6620]) References #1890: Improve skinnability of BASE

Fixed special table in disk usage summary.

comment:20 Changed 6 years ago by Nicklas Nordborg

(In [6621]) References #1890: Improve skinnability of BASE

Getting rid of some more hardcoded color values.

comment:21 Changed 6 years ago by Nicklas Nordborg

(In [6622]) References #1890: Improve skinnability of BASE

No outline on tabs since it can interfere with our own border.

comment:22 Changed 6 years ago by Nicklas Nordborg

(In [6623]) References #1890: Improve skinnability of BASE

Toolbar buttons from extensions are also 'interactable'.

comment:23 Changed 6 years ago by Nicklas Nordborg

(In [6624]) References #1890: Improve skinnability of BASE

Adjusments to vertical alignment of images, radiobuttons and checkboxes for different font sizes.

comment:24 Changed 6 years ago by Nicklas Nordborg

(In [6625]) References #1890: Improve skinnability of BASE

Remove left-over from debug.

comment:25 Changed 6 years ago by Nicklas Nordborg

(In [6626]) References #1890: Improve skinnability of BASE

Skin actions was never propagated to <body> so that dynamic attributes could be written to hidden <div>.

comment:26 Changed 5 years ago by Nicklas Nordborg

(In [6635]) References #1890: Improve skinnability of BASE

Fixed incorrect path to BASE logo.

comment:27 Changed 5 years ago by Nicklas Nordborg

(In [6645]) References #1890: Improve skinnability of BASE

Feature that tried to cut of text from options when it seems to be too long for a selection list was broken with the new CSS. Better to let the CSS control it.

comment:28 Changed 5 years ago by Nicklas Nordborg

Resolution: fixed
Status: assignedclosed

comment:29 Changed 5 years ago by Nicklas Nordborg

(In [6660]) References #1890: Improve skinnability of BASE

Fixes some styling issues found while testing IE.

comment:30 Changed 5 years ago by Nicklas Nordborg

(In [6661]) References #1890: Improve skinnability of BASE

Fixes some more styling and functionality issues found while testing IE.

comment:31 Changed 5 years ago by Nicklas Nordborg

(In [6663]) References #1890: Improve skinnability of BASE

Add possibility to disable skins on a page by setting <base:page noskin="true"> in the page definition.

Note: See TracTickets for help on using tickets.