Opened 6 years ago

Closed 6 years ago

#1872 closed defect (fixed)

The "Calendar" button on the Edit sample page does not work

Reported by: Nicklas Nordborg Owned by: everyone
Priority: trivial Milestone: BASE 3.3.2
Component: web Version:
Keywords: Cc:

Description

Nothing happens and no error messaged in debug console.

Change History (2)

comment:1 Changed 6 years ago by Nicklas Nordborg

Don't think any calendar button at all is working... The problem is that the taglib constructor is setting some default attributes, but they are cleared when the tag object is reused by Tomcat. The attributes that are set in the constructor must be re-set whenever the context is reset (eg. a call is made to setPageContext).

I have fixed this in the StylableTag class which now call initDefaultAttributes(). It is up to each subclass tag to implement this method.

comment:2 Changed 6 years ago by Nicklas Nordborg

Resolution: fixed
Status: newclosed

(In [6571]) Fixes #1872: The "Calendar" button on the Edit sample page does not work

Note: See TracTickets for help on using tickets.