Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#1369 closed defect (fixed)

A new array design does not get a registered date

Reported by: jari Owned by: everyone
Priority: major Milestone: BASE 2.13.1
Component: core Version: 2.13
Keywords: Cc:

Description

I am adding a new array design but there is no registered date associated to the new design. I tried with an extract and a registered date is automatically assigned to it. I also tried array batches and slides and these get a registered date.

Change History (7)

comment:1 Changed 11 years ago by Nicklas Nordborg

I can't reproduce this. It works just fine when I try it in BASE 2.13.

comment:2 in reply to:  1 Changed 11 years ago by jari

Replying to nicklas:

I can't reproduce this. It works just fine when I try it in BASE 2.13.

Can you try it on our production server? It is running 2.13.

comment:3 Changed 11 years ago by Nicklas Nordborg

It seems to work on the production server also. Look at the 'Test of registered' array design owned by the root user.

comment:4 Changed 11 years ago by jari

Hm, interesting. Check out 'noregdate design' owned by my admin account.

comment:5 Changed 11 years ago by Nicklas Nordborg

Component: webcore

It seems like this problem happens when selecting a platform with a variant. Eg. Illumina SNP. This triggers a different code path that doesn't set the registration date. Compare the two ArrayDesign.getNew() methods: http://base.thep.lu.se/browser/tags/2.13/src/core/net/sf/basedb/core/ArrayDesign.java#L104 -- 134

It seems like I was incorrect when stating that the registration date was set in a central location. It is not. I think we should also check the RawBioassay class for a similar problem since it also has more than one getNew() method.

comment:6 Changed 11 years ago by Nicklas Nordborg

Resolution: fixed
Status: newclosed

(In [5098]) Fixes #1369: A new array design does not get a registered date

No problem with the RawBioAssay?

comment:7 in reply to:  6 Changed 11 years ago by jari

Replying to nicklas:

No problem with the RawBioAssay

RawBioAssay works for me.

Note: See TracTickets for help on using tickets.