Opened 11 years ago

Closed 11 years ago

#1357 closed defect (fixed)

Incorrect HQL is generated when sorting on an aliased property that is followed by an association path

Reported by: Nicklas Nordborg Owned by: Nicklas Nordborg
Priority: minor Milestone: BASE 2.13
Component: core Version:
Keywords: Cc:

Description

The problem is in the ItemContext.configureQuery() method when we are sorting on a property like $abc.owner.name. Instead of generating a: left join abc.owner ... it generates left join xyz.owner ... where 'xyz' is the root alias used in the query.

Change History (2)

comment:1 Changed 11 years ago by Nicklas Nordborg

Status: newassigned

comment:2 Changed 11 years ago by Nicklas Nordborg

Resolution: fixed
Status: assignedclosed

(In [5046]) Fixes #1357: Incorrect HQL is generated when sorting on an aliased property that is followed by an association path

Note: See TracTickets for help on using tickets.