Opened 14 years ago

Closed 14 years ago

#975 closed defect (worksforme)

Experimental overview – error/erroneous warning – Duplicate sub-array index

Reported by: Johan Vallon-Christersson Owned by: everyone
Priority: major Milestone:
Component: core Version:
Keywords: Cc:

Description (last modified by Johan Vallon-Christersson)

Working in an experiment containing 3 raw bioassays, all from the same hybridization (arrayindex 1, 4, and 5 respectively). For clarification; the hybridization is performed using an Illumina BeadChip that contain a total of 6 arrays (index 1-6).

When displaying the experimental overview a warning was given “Duplicate sub-array index…”

When clicking the hybridization to verify that the warning was incorrectly given (the raw bioassays had separate array indices) the error below occurred (error 1 below).

After, changing the view (by simply going to a new view) and then returning to the experimental overview, the warning about reused array indices was not given.

When first trying to recreate the error (completely new experiment but the same layout) I note that the warning about duplicate sub-array index first appears after I change the validation options to ignore missing protocols.

Warning:
Duplicate sub-array index: 1 (used by HumanWG-6_V2 A)
Change array index on HumanWG-6_V2 A
Change array index on HumanWG-6_V2 A

However, this time an error is not given even if I click to change array index.

I then change the validation options again (change to give warning for missing protocols) and when doing so an error is given (error 2 below)

Once again, after changing the view (by simply going to a new view) and then returning to the experimental overview, the warning about reused array indices is not given.


java.lang.NullPointerException? on page /onk/views/experiments/overview/info.jsp Version BASE 2.6.1 (build #4191; schema #52) Web server Apache Tomcat/5.5.26 Database Server MySQL 5.0.51a-log Database Dialect org.hibernate.dialect.MySQLInnoDBDialect JDBC Driver com.mysql.jdbc.Driver (version 5.0) Java runtime Java(TM) SE Runtime Environment (1.6.0_04-b12), Sun Microsystems Inc. Operating system Linux i386 2.6.18-53.1.14.el5PAE Memory Total: 504.4 MB Free: 140.3 MB Max: 976.5 MB Browser Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.13) Gecko/20080311 Firefox/2.0.0.13 Error message Stack trace

java.lang.NullPointerException? ...at org.apache.jsp.views.experiments.overview.info_jsp._jspService(info_jsp.java:162) ...at org.apache.jasper.runtime.HttpJspBase?.service(HttpJspBase?.java:98) ...at javax.servlet.http.HttpServlet?.service(HttpServlet?.java:803) ...at org.apache.jasper.servlet.JspServletWrapper?.service(JspServletWrapper?.java:331) ...at org.apache.jasper.servlet.JspServlet?.serviceJspFile(JspServlet?.java:329) ...at org.apache.jasper.servlet.JspServlet?.service(JspServlet?.java:265) ...at javax.servlet.http.HttpServlet?.service(HttpServlet?.java:803) ...at org.apache.catalina.core.ApplicationFilterChain?.internalDoFilter(ApplicationFilterChain?.java:269)

...at org.apache.catalina.core.ApplicationFilterChain?.doFilter(ApplicationFilterChain?.java:188) ...at net.sf.basedb.clients.web.servlet.CharacterEncodingFilter?.doFilter(CharacterEncodingFilter?.java:72) ...at org.apache.catalina.core.ApplicationFilterChain?.internalDoFilter(ApplicationFilterChain?.java:215) ...at org.apache.catalina.core.ApplicationFilterChain?.doFilter(ApplicationFilterChain?.java:188) ...at org.apache.catalina.core.StandardWrapperValve?.invoke(StandardWrapperValve?.java:213) ...at org.apache.catalina.core.StandardContextValve?.invoke(StandardContextValve?.java:174) ...at org.apache.catalina.core.StandardHostValve?.invoke(StandardHostValve?.java:127) ...at org.apache.catalina.valves.ErrorReportValve?.invoke(ErrorReportValve?.java:117) ...at org.apache.catalina.core.StandardEngineValve?.invoke(StandardEngineValve?.java:108) ...at org.apache.catalina.connector.CoyoteAdapter?.service(CoyoteAdapter?.java:174) ...at org.apache.jk.server.JkCoyoteHandler?.invoke(JkCoyoteHandler?.java:200) ...at org.apache.jk.common.HandlerRequest?.invoke(HandlerRequest?.java:283) ...at org.apache.jk.common.ChannelSocket?.invoke(ChannelSocket?.java:773) ...at org.apache.jk.common.ChannelSocket?.processConnection(ChannelSocket?.java:703) ...at org.apache.jk.common.ChannelSocket?$SocketConnection?.runIt(ChannelSocket?.java:895) ...at org.apache.tomcat.util.threads.ThreadPool?$ControlRunnable?.run(ThreadPool?.java:689) ...at java.lang.Thread.run(Thread.java:619)

17 more...


java.lang.NullPointerException? on page /onk/views/experiments/overview/info.jsp Version BASE 2.6.1 (build #4191; schema #52) Web server Apache Tomcat/5.5.26 Database Server MySQL 5.0.51a-log Database Dialect org.hibernate.dialect.MySQLInnoDBDialect JDBC Driver com.mysql.jdbc.Driver (version 5.0) Java runtime Java(TM) SE Runtime Environment (1.6.0_04-b12), Sun Microsystems Inc. Operating system Linux i386 2.6.18-53.1.14.el5PAE Memory Total: 422.1 MB Free: 189.4 MB Max: 976.5 MB Browser Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.13) Gecko/20080311 Firefox/2.0.0.13 Error message Stack trace

java.lang.NullPointerException? ...at org.apache.jsp.views.experiments.overview.info_jsp._jspService(info_jsp.java:162) ...at org.apache.jasper.runtime.HttpJspBase?.service(HttpJspBase?.java:98) ...at javax.servlet.http.HttpServlet?.service(HttpServlet?.java:803) ...at org.apache.jasper.servlet.JspServletWrapper?.service(JspServletWrapper?.java:331) ...at org.apache.jasper.servlet.JspServlet?.serviceJspFile(JspServlet?.java:329) ...at org.apache.jasper.servlet.JspServlet?.service(JspServlet?.java:265) ...at javax.servlet.http.HttpServlet?.service(HttpServlet?.java:803) ...at org.apache.catalina.core.ApplicationFilterChain?.internalDoFilter(ApplicationFilterChain?.java:269)

...at org.apache.catalina.core.ApplicationFilterChain?.doFilter(ApplicationFilterChain?.java:188) ...at net.sf.basedb.clients.web.servlet.CharacterEncodingFilter?.doFilter(CharacterEncodingFilter?.java:72) ...at org.apache.catalina.core.ApplicationFilterChain?.internalDoFilter(ApplicationFilterChain?.java:215) ...at org.apache.catalina.core.ApplicationFilterChain?.doFilter(ApplicationFilterChain?.java:188) ...at org.apache.catalina.core.StandardWrapperValve?.invoke(StandardWrapperValve?.java:213) ...at org.apache.catalina.core.StandardContextValve?.invoke(StandardContextValve?.java:174) ...at org.apache.catalina.core.StandardHostValve?.invoke(StandardHostValve?.java:127) ...at org.apache.catalina.valves.ErrorReportValve?.invoke(ErrorReportValve?.java:117) ...at org.apache.catalina.core.StandardEngineValve?.invoke(StandardEngineValve?.java:108) ...at org.apache.catalina.connector.CoyoteAdapter?.service(CoyoteAdapter?.java:174) ...at org.apache.jk.server.JkCoyoteHandler?.invoke(JkCoyoteHandler?.java:200) ...at org.apache.jk.common.HandlerRequest?.invoke(HandlerRequest?.java:283) ...at org.apache.jk.common.ChannelSocket?.invoke(ChannelSocket?.java:773) ...at org.apache.jk.common.ChannelSocket?.processConnection(ChannelSocket?.java:703) ...at org.apache.jk.common.ChannelSocket?$SocketConnection?.runIt(ChannelSocket?.java:895) ...at org.apache.tomcat.util.threads.ThreadPool?$ControlRunnable?.run(ThreadPool?.java:689) ...at java.lang.Thread.run(Thread.java:619)

17 more...

Change History (6)

comment:1 Changed 14 years ago by Johan Vallon-Christersson

Description: modified (diff)

comment:2 Changed 14 years ago by Nicklas Nordborg

I don't think the NullPointerException? has anything to do with the validation. But I am not able to reproduce anything of this. Here is what I do:

  1. Create a new Hyb. Set the number of arrays to 6.
  2. Create a scan from the Hyb.
  3. Create three raw data sets from the scan. Give them array index 1, 2 and 3. Raw data type is Genepix.
  4. Import raw data to each raw bioassay. I used the test data from: http://base.thep.lu.se/browser/trunk/src/test/data/test.rawdata.import.txt
  5. Create a new experiment and add the three raw bioassays to it.
  6. Go to the 'Experiment overview'
  7. I get a few warnings/error. All are related to missing software/hardware/procotol, etc. No warning is related to the array index.
  8. Setting the 'missing protocol' option to 'ignore' works as expected. The warnings about missing protocol are no longer displayed. No NullPointerException? or other warnings related to the array index.

Do you have any more information about how this can be reproduced?

comment:3 Changed 14 years ago by Nicklas Nordborg

I think I have found the source for the NullPointerException?. See #976.

comment:4 Changed 14 years ago by Jari Häkkinen

Resolution: wontfix
Status: newclosed

We'll close this ticket for now since we cannot reproduce the problem.

comment:5 Changed 14 years ago by Jari Häkkinen

Resolution: wontfix
Status: closedreopened

comment:6 Changed 14 years ago by Jari Häkkinen

Resolution: worksforme
Status: reopenedclosed
Note: See TracTickets for help on using tickets.