Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#806 closed defect (fixed)

Experimental factor values display on Experiment page can only display one annotation of each type

Reported by: Nicklas Nordborg Owned by: Nicklas Nordborg
Priority: major Milestone: BASE 2.5
Component: web Version:
Keywords: Cc:

Description

Problem was posted on the mailing list:

We are trying to export our first experiment for real so we can submit it to ArrayExpress?, and initially it looked like everything had worked okay. But now we have found an error with the annotation that I wanted to ask you about. Our experiment is a two-colour one, and we have a factor which can take the value of mutant or wildtype. Both mutant and wildtype sample is applied to the hybridization (one per channel) and we then want the RawBioAssay? item to inherit its annotations. The only way we could find to do that was to inherit from both the samples, but then only one of them is exported into the tab2mage file, which presumably is not good enough for ArrayExpress?.

This is becuase BASE chooses the first of the inherited annotations values that it finds for sample, assigns and displays this as the factor value for the experiment.

BASE doesn't choose one of them. All inherited annotation values are always displayed.

BASE actually chooses one of them, at least as shown on the GUI here. It's not the exprimental factors section of the GUI parse that's relevant here, based on my understanding, but the Raw Bio assays section listing each raw bio assay included in the experiment. Since experimental factor values/annotation values has to be propagated through the Raw Bio assays.

For each Raw Bio assay in an experiment, you can only see or get one of the inherited values having inherited annotations from two different Sample items each from a line in the two channel hyb.

However, the inherited values are displayed as separate annotations for the raw bio assays on the 'Inherited annotations and protocol parameters section' of the view page.

It actually seems like the GUI only displays one of the inherited annotations on the Experiments page. This should of course be corrected to display all annotations. Note that this is just a display problem. All the inherited annotations are stored in the database and can be viewed from the Raw Bioassay page which doesn't have this bug.

Change History (6)

comment:1 Changed 14 years ago by Nicklas Nordborg

Summary: Experimental factor values display on Experiment page acn only display one annotation of each typeExperimental factor values display on Experiment page can only display one annotation of each type

comment:2 Changed 14 years ago by Nicklas Nordborg

The problem is that the web is using the AnnotationSet?.findAnnotation() method which can only return one annotation. We should probably deprecate this method and replace it with AnnotationSet?.findAnnotations() which should be able to return all annotations.

comment:3 Changed 14 years ago by Nicklas Nordborg

Owner: changed from everyone to Nicklas Nordborg
Status: newassigned

comment:4 Changed 14 years ago by Nicklas Nordborg

Resolution: fixed
Status: assignedclosed

(In [3875]) Fixes #806: Experimental factor values display on Experiment page can only display one annotation of each type

The same bug was also present in the Experiment overview

comment:5 Changed 14 years ago by Nicklas Nordborg

(In [3898]) References #806: Experimental factor values display on Experiment page can only display one annotation of each type

Fixed an accidental renaming of a deprecated method.

comment:6 Changed 14 years ago by Nicklas Nordborg

(In [4007]) References #806: Experimental factor values display on Experiment page can only display one annotation of each type

Added @since tag

Note: See TracTickets for help on using tickets.