Opened 14 years ago

Closed 14 years ago

#798 closed enhancement (duplicate)

Stopping job agent should stop jobs gracefully and set status killed in BASE.

Reported by: Jari Häkkinen Owned by: everyone
Priority: major Milestone:
Component: core Version:
Keywords: Cc:

Description


Change History (2)

comment:1 Changed 14 years ago by Jari Häkkinen

Now there is an error message saying something about interupt:

java.lang.InterruptedException
at java.lang.Object.wait(Native Method)
at java.lang.Object.wait(Object.java:474)
at java.lang.UNIXProcess.waitFor(UNIXProcess.java:165)
at net.sf.basedb.clients.jobagent.executors.ProcessJobExecutor.executeJob(ProcessJobExecutor.java:207)
at net.sf.basedb.clients.jobagent.JobRunner.run(JobRunner.java:123)
at java.lang.Thread.run(Thread.java:595)

comment:2 Changed 14 years ago by Nicklas Nordborg

Resolution: duplicate
Status: newclosed

Duplicate of #636.

Note: See TracTickets for help on using tickets.