Opened 15 years ago

Closed 15 years ago

#767 closed defect (fixed)

Migration fails if more than one user has the same quota

Reported by: Nicklas Nordborg Owned by: Nicklas Nordborg
Priority: minor Milestone: BASE 2.4.2
Component: migrate Version:
Keywords: Cc:

Description

The stacktrace is:

net.sf.basedb.core.ItemNotFoundException: Item not found: Quota[id=0]
   at net.sf.basedb.core.Quota.getById(Quota.java:140)
   at net.sf.basedb.clients.migrate.QuotaTransfer.getQuotaForTotal(QuotaTransfer.java:101)
   at net.sf.basedb.clients.migrate.UserTransfer.finalizeQuota(UserTransfer.java:320)
   at net.sf.basedb.clients.migrate.Migrater.run(Migrater.java:204)
   at net.sf.basedb.clients.migrate.Migrater.main(Migrater.java:602)

The migration will create new quota items, but only one for a given amount of bytes. The migration will detect if more than one user has the same quota and re-use an already existing quota. The problem is that the code for re-use assumes that the quota has already been saved to the database. In this case it has not and the migration should not try to load it.

Note! This step is not a critical one. Everything has already been transfered. The only remaining thing is to set the quota for users. The failure in this step will cause all users to remain at unlimited quota.

Change History (2)

comment:1 Changed 15 years ago by Nicklas Nordborg

Status: newassigned

comment:2 Changed 15 years ago by Nicklas Nordborg

Resolution: fixed
Status: assignedclosed

(In [3754]) Fixes #767: Migration fails if more than one user has the same quota

Note: See TracTickets for help on using tickets.