Opened 14 years ago

Closed 14 years ago

#707 closed defect (fixed)

Can't unlink items that have been put in the trashcan

Reported by: Nicklas Nordborg Owned by: Nicklas Nordborg
Priority: major Milestone: BASE 2.5
Component: web Version:
Keywords: Cc:

Description (last modified by Nicklas Nordborg)

Items that have been marked for removal can't be unlinked with other items when there is a many-to-many relation. I first found this when trying to remove a raw bioassay from an experiment. The same problem exists for labeled extracts and hybridizations and I suspect that the problem is present in a lot more places. The problem is usually visible on both the view page and the edit page. The edit dialogs should include all items. If possible, item that have been marked for deletion could be displayed in a different style. The view pages should also include all items. Here, the trashcan icon can be used to mark items that have been put in the trashcan.

I have a raw bioassay that is part of an experiment. The experiment has no analysed data. I mark the raw bioassay for deletion but in the trashcan I get the message that it can't be deleted since it is used in the experiment. So, I go to the "Edit experiment" to remove the raw bioassay but it is not listed there. It is not listed in the view page either so it is not possible to remove the raw bioassay from the experiment.

The only workaround is: go to the trashcan and restore the raw bioassay, then edit the experiment and remove the raw biassay from it. Mark the raw bioassay for removal again, go to the trashcan and delete it.

Change History (4)

comment:1 Changed 14 years ago by Nicklas Nordborg

Description: modified (diff)
Milestone: BASE 2.4BASE 2.5
Priority: trivialmajor
Summary: Can't remove raw bioassays from experimentCan't unlink items that have been put in the trashcan

comment:2 Changed 14 years ago by Nicklas Nordborg

Owner: changed from everyone to Nicklas Nordborg
Status: newassigned

comment:3 Changed 14 years ago by Nicklas Nordborg

(In [3888]) References #707: Can't unlink items that have been put in the trashcan

Fixes the problem for all items in the View and Array LIMS menus.

comment:4 Changed 14 years ago by Nicklas Nordborg

Resolution: fixed
Status: assignedclosed

(In [3890]) Fixes #707: Can't unlink items that have been put in the trashcan

Note: See TracTickets for help on using tickets.