Opened 15 years ago

Closed 15 years ago

#576 closed defect (fixed)

plugin web interface can't find (recent) file items emptied from trashcan

Reported by: base Owned by: Nicklas Nordborg
Priority: minor Milestone: BASE 2.3.1
Component: web Version:
Keywords: plugins Cc:

Description

How to reproduce this minor bug:

  1. try to import faulty data (e.g. with a trailing space or CaSe? issues) to a raw bioassay
  2. delete faulty file
  3. empty trashcan
  4. upload new (hopefully fixed) raw data file
  5. then click raw bioassay->Import...
  6. select the plugin type and configuration
  7. click next and you should get the following error

On page /base2dev/common/plugin/index.jsp Item not found: File[id=211]

I believe the web interface is cacheing some "recent items" but these are no longer in the db after the trashcan emptying.

logging out and in to the web interface clears the problem.

using autodetect (instead of selecting plugin+config) also clears the problem.

(Bob)

PS. I know that you don't have to empty the trashcan, and you can even overwrite files (nice new feature!) - I just found this by accident really.

Change History (4)

comment:1 Changed 15 years ago by Nicklas Nordborg

Milestone: BASE 2.4

I can verify this problem. Actually, it remembers the last file ID used or visited. So all you have to do is to go to the file manager, click on a file, delete it, empty the trashcan and then continue with 5) above.

I think the problem is generic for any type of item. If you delete an item and then start a plugin that asks for an item of that type, you will get the same error.

Note to developers! The plugin.jsp tries to load the item with ID taken from the ItemContext?.getId() method. A try-catch around the problematic code will probably solve the problem.

comment:2 Changed 15 years ago by Nicklas Nordborg

Milestone: BASE 2.4BASE 2.3.1

comment:3 Changed 15 years ago by Nicklas Nordborg

Owner: changed from Johan Enell to Nicklas Nordborg
Status: newassigned

comment:4 Changed 15 years ago by Nicklas Nordborg

Resolution: fixed
Status: assignedclosed

(In [3442]) Fixes #576.

Note: See TracTickets for help on using tickets.