Opened 15 years ago

Closed 15 years ago

#506 closed defect (invalid)

Tried to move a file a caused an error

Reported by: base Owned by: Johan Enell
Priority: minor Milestone:
Component: web Version:
Keywords: Cc:

Description

Tried to move a file from Administrator's hom account to template/raw data. I was logged in as root.

Options…   
Unexpected error
DatabaseException on page /filemanager/files/index.jsp
	
Version 	BASE 2.2.1 (build #0; schema #29)
Web server 	Apache Tomcat/5.5.17
Database Dialect 	org.hibernate.dialect.MySQLInnoDBDialect
JDBC Driver 	com.mysql.jdbc.Driver (version 5.0)
Java runtime 	Java(TM) 2 Runtime Environment, Standard Edition (1.5.0_09-b03), Sun Microsystems Inc.
Operating system 	Linux amd64 2.6.19-1.2895.fc6
Memory 	Total: 198.5 MB
Free: 40.9 MB
Max: 444.5 MB
Browser 	Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.1.2) Gecko/20070219 Firefox/2.0.0.2
Error message 	Duplicate entry 'Human_WG-Supp.Ref17.csv-5' for key 3
Stack trace 	

...at HibernateUtil.commit(HibernateUtil.java:861)
...at DbControl.commit(DbControl.java:383)
...at org.apache.jsp.filemanager.files.index_jsp._jspService(index_jsp.java:463)
...at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:97)
...at javax.servlet.http.HttpServlet.service(HttpServlet.java:802)
...at org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:332)
...at org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:314)
...at org.apache.jasper.servlet.JspServlet.service(JspServlet.java:264)

...at javax.servlet.http.HttpServlet.service(HttpServlet.java:802)
...at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:252)
...at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173)
...at net.sf.basedb.clients.web.servlet.CharacterEncodingFilter.doFilter(CharacterEncodingFilter.java:71)
...at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:202)
...at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173)
...at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:213)
...at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:178)
...at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:126)
...at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:105)
...at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:107)
...at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:148)
...at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:869)
...at org.apache.coyote.http11.Http11BaseProtocol$Http11ConnectionHandler.processConnection(Http11BaseProtocol.java:664)
...at org.apache.tomcat.util.net.PoolTcpEndpoint.processSocket(PoolTcpEndpoint.java:527)
...at org.apache.tomcat.util.net.LeaderFollowerWorkerThread.runIt(LeaderFollowerWorkerThread.java:80)
...at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:684)
...at java.lang.Thread.run(Thread.java:595)

Caused by: com.mysql.jdbc.exceptions.MySQLIntegrityConstraintViolationException
...at com.mysql.jdbc.SQLError.createSQLException(SQLError.java:931)
...at com.mysql.jdbc.MysqlIO.checkErrorPacket(MysqlIO.java:2870)
...at com.mysql.jdbc.MysqlIO.sendCommand(MysqlIO.java:1573)
...at com.mysql.jdbc.ServerPreparedStatement.serverExecute(ServerPreparedStatement.java:1169)
...at com.mysql.jdbc.ServerPreparedStatement.executeInternal(ServerPreparedStatement.java:693)
...at com.mysql.jdbc.PreparedStatement.executeUpdate(PreparedStatement.java:1404)
...at com.mysql.jdbc.PreparedStatement.executeUpdate(PreparedStatement.java:1318)
...at com.mysql.jdbc.PreparedStatement.executeUpdate(PreparedStatement.java:1303)
...at com.mchange.v2.c3p0.impl.NewProxyPreparedStatement.executeUpdate(NewProxyPreparedStatement.java:105)
...at org.hibernate.persister.entity.AbstractEntityPersister.update(AbstractEntityPersister.java:2403)
...at org.hibernate.persister.entity.AbstractEntityPersister.updateOrInsert(AbstractEntityPersister.java:2303)
...at org.hibernate.persister.entity.AbstractEntityPersister.update(AbstractEntityPersister.java:2603)
...at org.hibernate.action.EntityUpdateAction.execute(EntityUpdateAction.java:92)
...at org.hibernate.engine.ActionQueue.execute(ActionQueue.java:248)
...at org.hibernate.engine.ActionQueue.executeActions(ActionQueue.java:232)
...at org.hibernate.engine.ActionQueue.executeActions(ActionQueue.java:140)
...at org.hibernate.event.def.AbstractFlushingEventListener.performExecutions(AbstractFlushingEventListener.java:298)
...at org.hibernate.event.def.DefaultFlushEventListener.onFlush(DefaultFlushEventListener.java:27)
...at org.hibernate.impl.SessionImpl.flush(SessionImpl.java:1000)
...at org.hibernate.impl.SessionImpl.managedFlush(SessionImpl.java:338)
...at org.hibernate.transaction.JDBCTransaction.commit(JDBCTransaction.java:106)
...at HibernateUtil.commit(HibernateUtil.java:856)
...at DbControl.commit(DbControl.java:383)
...at org.apache.jsp.filemanager.files.index_jsp._jspService(index_jsp.java:463)
...at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:97)
...at javax.servlet.http.HttpServlet.service(HttpServlet.java:802)
...at org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:332)
...at org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:314)
...at org.apache.jasper.servlet.JspServlet.service(JspServlet.java:264)
...at javax.servlet.http.HttpServlet.service(HttpServlet.java:802)
...at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:252)
...at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173)
...at net.sf.basedb.clients.web.servlet.CharacterEncodingFilter.doFilter(CharacterEncodingFilter.java:71)
...at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:202)
...at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173)
...at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:213)
...at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:178)
...at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:126)
...at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:105)
...at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:107)
...at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:148)
...at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:869)
...at org.apache.coyote.http11.Http11BaseProtocol$Http11ConnectionHandler.processConnection(Http11BaseProtocol.java:664)
...at org.apache.tomcat.util.net.PoolTcpEndpoint.processSocket(PoolTcpEndpoint.java:527)
...at org.apache.tomcat.util.net.LeaderFollowerWorkerThread.runIt(LeaderFollowerWorkerThread.java:80)
...at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:684)
...at java.lang.Thread.run(Thread.java:595)

Change History (1)

comment:1 Changed 15 years ago by Nicklas Nordborg

Resolution: invalid
Status: newclosed

The error message might be a bit cryptic but actually means that there already exists a file with the name 'Human_WG-Supp.Ref17.csv' in the directory.

Note: See TracTickets for help on using tickets.