Opened 15 years ago

Closed 15 years ago

#462 closed defect (duplicate)

Incompatible conditional operand types String and int

Reported by: base Owned by: Johan Enell
Priority: major Milestone: BASE 2.1.2
Component: web Version: 2.1.1
Keywords: Cc:

Description

Hello, I'm get the following error while trying to add annotation types to an experiment through the web interface. (see attached screenshot)

org.apache.jasper.JasperException?: Unable to compile class for JSP

An error occurred at line: 482 in the jsp file: /admin/annotationtypes/list_annotationtypes.jsp Generated servlet error: Incompatible conditional operand types String and int

org.apache.jasper.compiler.DefaultErrorHandler?.javacError(DefaultErrorHandler?.java:84) org.apache.jasper.compiler.ErrorDispatcher?.javacError(ErrorDispatcher?.java:328) org.apache.jasper.compiler.JDTCompiler.generateClass(JDTCompiler.java:409) org.apache.jasper.compiler.Compiler.compile(Compiler.java:288) org.apache.jasper.compiler.Compiler.compile(Compiler.java:267) org.apache.jasper.compiler.Compiler.compile(Compiler.java:255) org.apache.jasper.JspCompilationContext?.compile(JspCompilationContext?.java:563) org.apache.jasper.servlet.JspServletWrapper?.service(JspServletWrapper?.java:293) org.apache.jasper.servlet.JspServlet?.serviceJspFile(JspServlet?.java:314) org.apache.jasper.servlet.JspServlet?.service(JspServlet?.java:264) javax.servlet.http.HttpServlet?.service(HttpServlet?.java:802) net.sf.basedb.clients.web.servlet.CharacterEncodingFilter?.doFilter(CharacterEncodingFilter?.java:71)

Change History (1)

comment:1 Changed 15 years ago by Jari Häkkinen

Resolution: duplicate
Status: newclosed

Duplicate of #463.

Note: See TracTickets for help on using tickets.