Opened 15 years ago

Closed 15 years ago

Last modified 15 years ago

#459 closed defect (fixed)

Better error message if plugin jar can't be found

Reported by: Nicklas Nordborg Owned by: Martin Svensson
Priority: minor Milestone: BASE 2.2
Component: core Version:
Keywords: Cc:

Description (last modified by Nicklas Nordborg)

The stacktrace that is shown when a trying to install a plugin and the JAR file can't be found is not very informative:

Could not instantiate plugin class
...
Caused by: java.util.zip.ZipException

We could probably let the JarClassLoader? check that the JAR file exists and throw a better error message if it doesn't.

Change History (3)

comment:1 Changed 15 years ago by Nicklas Nordborg

Description: modified (diff)

comment:2 Changed 15 years ago by Martin Svensson

Resolution: fixed
Status: newclosed

(In [3052]) Fixes #459 Better error message if plugin jar can't be found

comment:3 Changed 15 years ago by Nicklas Nordborg

(In [3078]) References #459: Better error message if plugin jar can't be found

Throw InvalidDataException? instead of IOException to make the web application display a simple error message instead of a complete stack trace.

Note: See TracTickets for help on using tickets.