Opened 15 years ago

Closed 15 years ago

#387 closed defect (invalid)

Can't remove reporters from a Reporter List

Reported by: simon Owned by: Nicklas Nordborg
Priority: minor Milestone:
Component: core Version: 2.0.1
Keywords: Cc:

Description

Steps performed: Selected a bunch of reporters via their ID (approx. 2200) Created a new Reporter List from them (all pages) Tried to remove 1 and/or several reporters from that new list. The following error is always thrown:

Base version 2.0 (build #0; schema #12) Web server Apache Tomcat/5.0 Database Dialect org.hibernate.dialect.MySQLInnoDBDialect JDBC Driver com.mysql.jdbc.Driver (version 3.1) Java runtime Java(TM) 2 Runtime Environment, Standard Edition (1.5.0_07-b03), Sun Microsystems Inc. Operating system Linux i386 2.6.16.21-0.13-smp Memory Total: 52.7 MB Free: 11.6 MB Max: 496.2 MB Browser Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.7) Gecko/20060913 Fedora/1.5.0.7-1.fc5 Firefox/1.5.0.7 pango-text Error message org.hibernate.util.MarkerObject? Stack trace

...at ReporterList?.removeReporter(ReporterList?.java:210) ...at org.apache.jsp.views.reporterlists.reporters.index_jsp._jspService(index_jsp.java:134) ...at org.apache.jasper.runtime.HttpJspBase?.service(HttpJspBase?.java:94) ...at javax.servlet.http.HttpServlet?.service(HttpServlet?.java:856)

Cheers, Simon

Change History (4)

comment:1 Changed 15 years ago by base

Forgot to paste the Exception line:

java.lang.ClassCastException? on page /base2/views/reporterlists/reporters/index.jsp

comment:2 Changed 15 years ago by Nicklas Nordborg

Priority: blockerminor

I am not able to reproduce this. I can remove reporters without problem. There are a few which has experienced the same ClassCastException? for the MarkerObject? on the Hibernate forum (see http://forum.hibernate.org/viewtopic.php?t=959868), but it seems to only happen randomly in their case. It would be a rare case of randomness if I never get the error but Simon always does.

The "build #0" indicates that the installation was built from source and not installed from the binary distribution. Other differences are that I use Tomcat 5.5.17 and Java 1.5.0_06-b05. Maybe something of this is casuing the problem?

comment:3 Changed 15 years ago by simon

Turns out it is a bug in hibernate. I've been flip flopping between Hibernate 3.1.3 and 3.2CR5 to check stability. With 3.1.3 and -server flag in Tomcat set, it works fine. The bug appears to be in 3.2CR5. The one benefit to 3.2CR5, is it solves the bug requiring the -server flag to be set in Tomcat. I guess you win some you lose some. I'll stick with 3.1.3 for all futher tests.

comment:4 Changed 15 years ago by Nicklas Nordborg

Resolution: invalid
Status: newclosed

This report was posted earlier today in the Hibernate bug tracking system: http://opensource.atlassian.com/projects/hibernate/browse/HHH-2142

I think it explains the problem and I hope they will fix it before the final release. The next time, please tell us that you have done changes to BASE.

Regarding the -server option, I think it has other valus than just fixing the annoying bug. In theory, it should generate more optimized code. However, it would be nice to not have it when debugging because the startup time is much longer.

Note: See TracTickets for help on using tickets.