Opened 15 years ago

Closed 15 years ago

#367 closed defect (fixed)

Error on "About" update

Reported by: cgwiita@… Owned by: Nicklas Nordborg
Priority: minor Milestone: BASE 2.1
Component: web Version: trunk
Keywords: Cc:

Description

Built from subversion checkout, up to changeset 2622. Build and install went well, as did the migration of 1.2 data (which was mainly what I was testing). Trying to update the "About" page (Administrate->Server configuration->About) fails on OK. Getting this error:

HTTP Status 500 -

type Exception report

message

description The server encountered an internal error () that prevented it from fulfilling this request.

exception

org.apache.jasper.JasperException?: Unable to compile class for JSP

An error occurred at line: 46 in the jsp file: /admin/server/submit_server.jsp Generated servlet error: The method parseBytes(String, Long) in the type Values is not applicable for the arguments (String, int)

org.apache.jasper.compiler.DefaultErrorHandler?.javacError(DefaultErrorHandler?.java:84) org.apache.jasper.compiler.ErrorDispatcher?.javacError(ErrorDispatcher?.java:328) org.apache.jasper.compiler.JDTCompiler.generateClass(JDTCompiler.java:414) org.apache.jasper.compiler.Compiler.compile(Compiler.java:297) org.apache.jasper.compiler.Compiler.compile(Compiler.java:276) org.apache.jasper.compiler.Compiler.compile(Compiler.java:264) org.apache.jasper.JspCompilationContext?.compile(JspCompilationContext?.java:563) org.apache.jasper.servlet.JspServletWrapper?.service(JspServletWrapper?.java:303) org.apache.jasper.servlet.JspServlet?.serviceJspFile(JspServlet?.java:314) org.apache.jasper.servlet.JspServlet?.service(JspServlet?.java:264) javax.servlet.http.HttpServlet?.service(HttpServlet?.java:802) net.sf.basedb.clients.web.servlet.CharacterEncodingFilter?.doFilter(CharacterEncodingFilter?.java:71)

note The full stack trace of the root cause is available in the Apache Tomcat/5.5.17 logs. Apache Tomcat/5.5.17

System info:

Base version 2.0 (build #0; schema #13) Web server Apache Tomcat/5.5.17 Database Dialect org.hibernate.dialect.MySQLInnoDBDialect JDBC Driver com.mysql.jdbc.Driver (version 3.1) Java runtime Java(TM) 2 Runtime Environment, Standard Edition (1.5.0_07-b03), Sun Microsystems Inc. Operating system Linux i386 2.6.17-1.2174_FC5smp

Change History (2)

comment:1 Changed 15 years ago by Nicklas Nordborg

Milestone: BASE 2.1
Owner: changed from Johan Enell to Nicklas Nordborg
Status: newassigned
Version: trunk

comment:2 Changed 15 years ago by Nicklas Nordborg

Resolution: fixed
Status: assignedclosed

(In [2647]) Fixes #367: Error on "About" update

Note: See TracTickets for help on using tickets.