Opened 15 years ago

Closed 15 years ago

#363 closed defect (fixed)

Updating from RC1 throws NullPointerException

Reported by: Nicklas Nordborg Owned by: Nicklas Nordborg
Priority: minor Milestone: BASE 2.0.1
Component: install Version:
Keywords: Cc:

Description (last modified by Nicklas Nordborg)

> * Problem 1: using binary BASE 2.0
> When running the 'updatedb.sh' script, java crashes after building the  
> initial database:
> 
> [0%]    Building database........................
> [30%]   Database built successfully.
> 
> java.lang.NullPointerException
>          at net.sf.basedb.core.Update.getSchemaVersion(Update.java:319)
>          at  
> net.sf.basedb.core.Update.adjustExistingItems(Update.java:599)
>          at net.sf.basedb.install.InitDB.main(InitDB.java:66)

The problem is that there is no SchemaVersion? information in RC1. It is probably safe to return 0 from that method since if there is no schema version all updates must be executed.

Change History (3)

comment:1 Changed 15 years ago by Nicklas Nordborg

Description: modified (diff)

comment:2 Changed 15 years ago by Jari Häkkinen

(In [2642]) Refs #363. Added information about the RC1 to 2.0 updating problem.

comment:3 Changed 15 years ago by Nicklas Nordborg

Resolution: fixed
Status: newclosed

(In [2650]) Fixes #363: Updating from RC1 throws NullPointerException?

Note: See TracTickets for help on using tickets.