Opened 15 years ago

Closed 15 years ago

#284 closed defect (fixed)

uploading file with same name as existing file gives error

Reported by: DionLepp Owned by: Johan Enell
Priority: minor Milestone:
Component: web Version:
Keywords: Cc:

Description

If you attempt to upload a file with the same name as a file that is already uploaded, you get the error message below, instead of asking if you would like to replace the original or rename the current file.

type Exception report

message

description The server encountered an internal error () that prevented it from fulfilling this request.

exception

javax.servlet.ServletException?: File already exists:<br>Another file with the same name already exists: {1}

org.apache.jasper.runtime.PageContextImpl?.doHandlePageException(PageContextImpl?.java:858) org.apache.jasper.runtime.PageContextImpl?.handlePageException(PageContextImpl?.java:791) org.apache.jsp.filemanager.upload.progress_jsp._jspService(org.apache.jsp.filemanager.upload.progress_jsp:347) org.apache.jasper.runtime.HttpJspBase?.service(HttpJspBase?.java:97) javax.servlet.http.HttpServlet?.service(HttpServlet?.java:802) org.apache.jasper.servlet.JspServletWrapper?.service(JspServletWrapper?.java:332) org.apache.jasper.servlet.JspServlet?.serviceJspFile(JspServlet?.java:314) org.apache.jasper.servlet.JspServlet?.service(JspServlet?.java:264) javax.servlet.http.HttpServlet?.service(HttpServlet?.java:802) net.sf.basedb.clients.web.servlet.CharacterEncodingFilter?.doFilter(CharacterEncodingFilter?.java:71)

root cause

net.sf.basedb.clients.web.WebException?: File already exists:<br>Another file with the same name already exists: {1}

org.apache.jsp.filemanager.upload.upload_jsp._jspService(org.apache.jsp.filemanager.upload.upload_jsp:122) org.apache.jasper.runtime.HttpJspBase?.service(HttpJspBase?.java:97) javax.servlet.http.HttpServlet?.service(HttpServlet?.java:802) org.apache.jasper.servlet.JspServletWrapper?.service(JspServletWrapper?.java:332) org.apache.jasper.servlet.JspServlet?.serviceJspFile(JspServlet?.java:314) org.apache.jasper.servlet.JspServlet?.service(JspServlet?.java:264) javax.servlet.http.HttpServlet?.service(HttpServlet?.java:802) net.sf.basedb.clients.web.servlet.CharacterEncodingFilter?.doFilter(CharacterEncodingFilter?.java:71)

note The full stack trace of the root cause is available in the Apache Tomcat/5.5.15 logs.

Change History (1)

comment:1 Changed 15 years ago by Johan Enell

Resolution: fixed
Status: newclosed

Fixed in changeset [2375]

Note: See TracTickets for help on using tickets.