Opened 16 years ago

Closed 16 years ago

#232 closed defect (fixed)

Only root can list events for biomaterials

Reported by: Nicklas Nordborg Owned by: Nicklas Nordborg
Priority: major Milestone: BASE 2.0 RC2
Component: core Version:
Keywords: Cc:

Description

The query that returns BioMaterialEvent:s only returns items if the root user is logged in. All other users get an empty result, even if the logged in user owns all biomaterials in question.

The problem is that the BioMaterialEvent? hasn't implemented a QueryRuntimeFilter? that matches the initPermissions method. The default filter is role-based and no roles have specific permissions to events.

Change History (2)

comment:1 Changed 16 years ago by Nicklas Nordborg

Status: newassigned

comment:2 Changed 16 years ago by Nicklas Nordborg

Resolution: fixed
Status: assignedclosed

(In [2256]) Fixes #232: Only root can list events for biomaterials

Note: See TracTickets for help on using tickets.