Opened 16 years ago

Closed 16 years ago

#214 closed defect (fixed)

Inherit annotations throw NullPointerException

Reported by: nicklas (mail from Longfei Yu <lyu@… Owned by: Nicklas Nordborg
Priority: minor Milestone: BASE 2.0 RC2
Component: web Version:
Keywords: Cc:

Description

Actually, I got the error when I click the inherited annotation in Extract,..., Raw Bioassay, and so on. Here is the error: type Exception report

message

description The server encountered an internal error () that prevented it from fulfilling this request.

exception java.lang.NullPointerException? org.apache.jsp.common.annotations.inherit_jsp.generateJoustTree(org.apac he.jsp.common.annotations.inherit_jsp:73) org.apache.jsp.common.annotations.inherit_jsp._jspService(org.apache.jsp .common.annotations.inherit_jsp:263) org.apache.jasper.runtime.HttpJspBase?.service(HttpJspBase?.java:97)

javax.servlet.http.HttpServlet?.service(HttpServlet?.java:802)

org.apache.jasper.servlet.JspServletWrapper?.service(JspServletWrapper?.ja va:332) org.apache.jasper.servlet.JspServlet?.serviceJspFile(JspServlet?.java:314) org.apache.jasper.servlet.JspServlet?.service(JspServlet?.java:264)

javax.servlet.http.HttpServlet?.service(HttpServlet?.java:802)

net.sf.basedb.clients.web.servlet.CharacterEncodingFilter?.doFilter(Chara cterEncodingFilter.java:72)

note The full stack trace of the root cause is available in the Apache Tomcat/5.5.14 logs.

Change History (1)

comment:1 Changed 16 years ago by Nicklas Nordborg

Resolution: fixed
Status: newclosed

(In [2217]) Fixes #214: Inherit annotations throw NullPointerException?. Happened when an item had parents with annotations, but didn't have any annotations by itself.

Note: See TracTickets for help on using tickets.