Opened 7 years ago

Closed 7 years ago

#1824 closed defect (fixed)

The services list page may display obsolete error messages

Reported by: Nicklas Nordborg Owned by: everyone
Priority: trivial Milestone: BASE 3.3
Component: web Version:
Keywords: Cc:

Description

There are cases when a service fails to load at startup. The error message/stack trace is then displayed in the Administrate -> Service list page. If the cause of the error is fixed and the service is re-started from the list page, the error is gone, but if the service is re-started by some other means (eg. via a custom menu not going through the services api) the old error message is still visible.

Change History (2)

comment:1 Changed 7 years ago by Nicklas Nordborg

The opposite situation can also happen. If the service is running and then restarted via a custom menu that is resulting in an error, the error is not visible in the services lists.

comment:2 Changed 7 years ago by Nicklas Nordborg

Resolution: fixed
Status: newclosed

(In [6500]) Fixes #1824: The services list page may display obsolete error messages

This fixes the display of obsolete error messages by simply ignoring any stored errors if the service is running.

The opposite situation require that extensions cooperate since there is no way the BASE core can know about an exception that happens outside of it's control. To make it easier for extensions they should now use the new method Services.restart() to restart a service.

Note: See TracTickets for help on using tickets.