Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#1792 closed defect (fixed)

Incorrect average method specified in IntensityTransform

Reported by: Nicklas Nordborg Owned by: everyone
Priority: critical Milestone: BASE 3.2.4
Component: core Version:
Keywords: Cc:

Description (last modified by Nicklas Nordborg)

The possibility to store log-transformed data values in BASE was introduced a long time by #1120 (BASE 2.12). The information is stored as a "flag" (=IntensityTransform) on the BioAssaySet level.

Since the transformation changes the rules how averages (over the spot intensities) are calculated the IntensityTransform flag was linked with the average method to use (a Formula.AverageMethod object).

The problem is that incorrect average method was selected. The correct should be:

  • NONE: Geometric
  • LOG2: Arithmetic
  • LOG10: Arithmetic

Change History (3)

comment:1 Changed 8 years ago by Nicklas Nordborg

Resolution: fixed
Status: newclosed

(In [6364]) Fixes #1792: Incorrect average method specified in IntensityTransform?

comment:2 Changed 8 years ago by Nicklas Nordborg

Description: modified (diff)

comment:3 Changed 8 years ago by Nicklas Nordborg

(In [6365]) References #1792: Normalizers should store data in the same transform as the source data

Fixed for the MedianRationNormalization plug-in. For 1-channel data, we use whatever that is stored in the database so we don't have to un-log and log data if the source is log-transformed.

For 2-channel data, log-transformed source data is first untransformed and then log-transformed again at the end.

Note: See TracTickets for help on using tickets.