Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#1781 closed defect (fixed)

Can't copy transformation for BASE 1 plug-in with enum parameters

Reported by: Nicklas Nordborg Owned by: Nicklas Nordborg
Priority: major Milestone: BASE 3.2.4
Component: coreplugins Version:
Keywords: Cc:

Description

At first, it seems to work, and the job configuration dialog is filled with parameter values from old transformation. But there are two separate problems:

  • Clicking next result in error message like: The value 'X' isn't allowed for parameter 'Y'.
  • Clicking on parameter 'Y' in the parameter list clears the copied value and the 'not specified' option is selected even though 'X' actually exists in the dropdown list.

Change History (4)

comment:1 Changed 8 years ago by Nicklas Nordborg

This issue is caused by the fix for #1437 which changed how enum values are stored in the database.

Enum values are actually key/value pairs where key is typically a number not visible to the user and the value is the text that is visible in the parameter values list. When configuring a plug-in it is only the 'key' values that are sent between the browser/server/plug-in code. Normally this works fine, since it is easy to find a 'value' given the 'key'.

However #1437 changed the behavior of the BASE 1 plug-in executor so that in the final step the 'value' is saved in the database instead of the 'key'. This causes a problem for the 'copy transformation' function which simply copies all values stored in the database and send them as parameters to the plug-in. This means that now the 'value' values are sent and not the 'key' values.

  • The The value 'X' isn't allowed for parameter 'Y' is caused by the BASE 1 plug-in executor not being prepared to handle both 'key' or 'value' values in the request.
  • The GUI should also be fixed so that if the value in the request is not found among the 'key' values in the list, it should look among the 'value' values.

comment:2 Changed 8 years ago by Nicklas Nordborg

Owner: changed from everyone to Nicklas Nordborg
Status: newassigned

comment:3 Changed 8 years ago by Nicklas Nordborg

Resolution: fixed
Status: assignedclosed

(In [6346]) Fixes #1781: Can't copy transformation for BASE 1 plug-in with enum parameters

Fixed in the GUI by also letting the configuration dialog also search the text of selection lists if no match is found among the key values.

Fixed in the core by adding an option to ParameterType that enable searching the values if no matching key is found. The BASE1 plug-in executer enables this option for all enumeration parameters.

comment:4 Changed 8 years ago by Nicklas Nordborg

(In [6375]) References #1781: Can't copy transformation for BASE 1 plug-in with enum parameters

The fix was not completely merged to the trunk.

Note: See TracTickets for help on using tickets.