Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#1777 closed defect (fixed)

Error messages for extensions that fail to install are forgotten after installing other extensions

Reported by: Nicklas Nordborg Owned by: everyone
Priority: minor Milestone: BASE 3.2.4
Component: web Version:
Keywords: Cc:

Description

This issue is a bit hard to reproduce, but the outline is a follows:

  • 2 different extensions are needed. At least one of them should contain resources that are extracted to the www/extensions/ directory.
  • Begin by installing both of them.
  • Prepare to trigger an error condition for one of the extensions by write-protecting the www/extensions/xxxx.jar directory and all files in all subdirectories (xxxx.jar should be the file name of the extension).
  • Try to re-install the extension. This should result in a error message about no permission to write files to the directory from the previous step.
  • Try to re-install the other extension. This should work.
  • Now, click on the extension that failed to install in the 'By file' branch of the tree to the left. The details section displays a stacktrace:
java.lang.NullPointerException
...at org.apache.jsp.admin.extensions.details_jsp._jspService(details_jsp.java:866)
...at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:70)
...at javax.servlet.http.HttpServlet.service(HttpServlet.java:728)
...

This is caused by the error messages from the failed installation are no longer available after the successful installation that happened after.

Change History (2)

comment:1 Changed 9 years ago by Nicklas Nordborg

Resolution: fixed
Status: newclosed

(In [6340]) Fixes #1777: Error messages for extensions that fail to install are forgotten after installing other extensions

The old installation results are now copied over to the new ProcessResults instance. Uninstalling an extension should remove the old results, but a weak hash map is used just in case something forgotten...

comment:2 Changed 9 years ago by Nicklas Nordborg

(In [6377]) References #1777: Error messages for extensions that fail to install are forgotten after installing other extensions

The fix was not completely merged to the trunk.

Note: See TracTickets for help on using tickets.