Opened 10 years ago

Closed 10 years ago

#1692 closed defect (fixed)

Not allowed to change a project even if user has RUWD permission in the project

Reported by: Jari Häkkinen Owned by: everyone
Priority: major Milestone: BASE 3.1.2
Component: web Version:
Keywords: Cc:

Description

If the user looks at the project properties the view will show only RU privileges even if members listing pane show more privileges.

Change History (2)

comment:1 Changed 10 years ago by Nicklas Nordborg

Milestone: BASE 3.1.2

Looking at the relevant code in Project.initPermissions() (line 247) I think that this is by design. The permissions given to a user or group as part of the project membership are applied to the items that are part of the project and not the actual project item. Only the owner of the project (or a global administrator) has permission to change it.

But I can't really remember why it was decided to be that way (the code is over 7 years old and has been there since long before BASE 2.0) and I think it should be changed so that the membership permissions also apply to the project item.

comment:2 Changed 10 years ago by Nicklas Nordborg

Resolution: fixed
Status: newclosed

(In [6054]) Fixes #1692: Not allowed to change a project even if user has RUWD permission in the project

Note: See TracTickets for help on using tickets.