Opened 13 years ago

Closed 13 years ago

#1352 closed defect (fixed)

Error 'Unable to resolve property: block' when exporting raw data

Reported by: Nicklas Nordborg Owned by: Nicklas Nordborg
Priority: major Milestone: BASE 2.13
Component: web Version:
Keywords: Cc:

Description

This error occurs if the '[Feat] Block' column is selected for export on the raw data list page for a raw bioassay. The full stack trace is:

java.io.IOException: Unable to resolve property: block
at net.sf.basedb.clients.web.plugins.SimpleExport.exportProperties(SimpleExport.java:631)
at net.sf.basedb.clients.web.plugins.SimpleExport.performExport(SimpleExport.java:331)
at net.sf.basedb.core.plugin.AbstractExporterPlugin.run(AbstractExporterPlugin.java:144)
at net.sf.basedb.core.PluginExecutionRequest.invoke(PluginExecutionRequest.java:110)
at net.sf.basedb.core.PluginExecutionRequest.run(PluginExecutionRequest.java:135)
at java.lang.Thread.run(Thread.java:619)
Caused by: net.sf.basedb.core.BaseException: Unable to resolve property: block
at net.sf.basedb.core.Metadata.getPropertyValue(Metadata.java:363)
at net.sf.basedb.clients.web.plugins.DataQueryWrapper.getData(DataQueryWrapper.java:84)
at net.sf.basedb.clients.web.plugins.DataQueryWrapper.getData(DataQueryWrapper.java:38)
at net.sf.basedb.clients.web.plugins.SimpleExport.exportProperties(SimpleExport.java:600)
... 5 more
Caused by: org.hibernate.HibernateException: Unable to resolve property: block
at org.hibernate.tuple.entity.EntityMetamodel.getPropertyIndex(EntityMetamodel.java:487)
at org.hibernate.tuple.entity.AbstractEntityTuplizer.getPropertyValue(AbstractEntityTuplizer.java:302)
at org.hibernate.persister.entity.AbstractEntityPersister.getPropertyValue(AbstractEntityPersister.java:3600)
at net.sf.basedb.core.Metadata.getPropertyValue(Metadata.java:356)
... 8 more

Change History (3)

comment:1 Changed 13 years ago by Nicklas Nordborg

Milestone: BASE 2.13

comment:2 Changed 13 years ago by Nicklas Nordborg

Owner: changed from everyone to Nicklas Nordborg
Status: newassigned

comment:3 Changed 13 years ago by Nicklas Nordborg

Resolution: fixed
Status: assignedclosed

(In [5028]) Fixes #1352: Error 'Unable to resolve property: block' when exporting raw data

Note: See TracTickets for help on using tickets.