Opened 13 years ago

Closed 13 years ago

#1326 closed defect (fixed)

Base1PluginExecuter doesn't recognise 'intensityX' spot field if X=number of channels

Reported by: Nicklas Nordborg Owned by: everyone
Priority: major Milestone: BASE 2.12.1
Component: core Version: 2.12
Keywords: Cc:

Description (last modified by Nicklas Nordborg)

BASE 1 plug-ins should be allowed to specify 'intensity1', 'intensity2', etc. as spot fields to export, where the number on the end is allowed to be between 1 and the number of channels in the experiment.

Due to a bug in the parser the last columns is lost and not recognised as a valid value. Eg. in a two-channel experiment, 'intensity1' is ok, but 'intensity2' results in:

Unknown spot field: intensity2 (you can add this field using a formula)

The workaround is to add a formula with name='intensity2' and the expression: rawCh(2)

Note to developers. The problem is with the end condition in the loop on line 273 in FieldConverter:

for (int i = 1; i < source.getRawDataType().getChannels(); ++i)

It should be:

for (int i = 1; i <= source.getRawDataType().getChannels(); ++i)
                   ^

Change History (2)

comment:1 Changed 13 years ago by Nicklas Nordborg

Description: modified (diff)

comment:2 Changed 13 years ago by Nicklas Nordborg

Resolution: fixed
Status: newclosed

(In [4960]) Fixes #1326: Base1PluginExecuter doesn't recognise 'intensityX' spot field if X=number of channels

Note: See TracTickets for help on using tickets.