Opened 12 years ago

Closed 12 years ago

#1306 closed defect (fixed)

File browser fails if wrong project is selected when browsing a directory shared to another project

Reported by: Jari Häkkinen Owned by: Martin Svensson
Priority: major Milestone: BASE 2.11.1
Component: web Version: 2.11
Keywords: Cc:

Description

See the attached screen dump for the error message.

The problem rises in a situation where a user only has access to files and directories through projects only. The problem cannot be circumvented, the user must set each of his projects active until finding the project giving him read permissions. Then he must select another directory view in the file browser before setting the other project active. Now, he will gain access to the project files and directories.

Attachments (1)

FileBrowsingError.png (50.0 KB) - added by Jari Häkkinen 12 years ago.

Download all attachments as: .zip

Change History (6)

Changed 12 years ago by Jari Häkkinen

Attachment: FileBrowsingError.png added

comment:1 Changed 12 years ago by Nicklas Nordborg

What is the 'defect' in this situation? It is the same error message (although a bit uglier due to the multiple-frame nature of the file browser) that is displayed if a user tries to access any kind of item that the user doesn't have access to.

I am not sure what you mean with the switching of projects/directories in the last two sentences.

I am not even sure how you get to the error message to begin with. Can you give a better description of how to reproduce this?

comment:2 Changed 12 years ago by Jari Häkkinen

User1 creates two directories and shares (with R) these to one project each.

dir1 - proj1 dir2 - proj2

User2 is added as a RU member to both proj1 and proj2. The only way user2 is allowed to read dir1 or dir2 is by setting the appropriate project active. If user2 has no project active then he cannot access either of dir1 or dir2.

User2 sets proj1 active and browses through to dir1, then selects to view something else, and then returns to the file view. All will be fine and the content of dir1 is shown.

BUT

User2 sets proj1 active and browses through to dir1, then selects to view something else, then he sets proj2 as active project, and then returns to the file view ... BASE will respond with the message in the attached file.

One way to resolve the above is to set the appropriate project active because then the file view will work again. The file view will be broken for user2 until he sets the proper project active. In the above description we remember the path but in a real life setting one may not remember which project was active the last time in the file view. So, for the user to resolve the issue, he should view files and set each project active until the file view starts working again. Now he can select another more neutral directory to view, then set the project he wanted to be active (proj2 here) and browse through to dir2.

(The other way is to reset list settings but that is usually not something one likes to do since all filter settings are destroyed.)

If the file view fails because of access denied BASE should react with displaying home or something neutral.

comment:3 Changed 12 years ago by Nicklas Nordborg

This description makes a lot more sense than the original one. The root of the problem is that BASE remembers the most recently browsed directory. If this directory is no longer accessible the proper action is to display the default directory which in most cases is the home directory.

The same thing happens if the directory has been deleted but this problem can't be solved by switching projects. In this case the 'File->Reset list settings' must be used.

comment:4 Changed 12 years ago by Martin Svensson

Owner: changed from everyone to Martin Svensson
Status: newassigned

comment:5 Changed 12 years ago by Martin Svensson

Resolution: fixed
Status: assignedclosed

(In [4924]) Fixes #1306 File browser fails if wrong project is selected when browsing a directory shared to another project

Note: See TracTickets for help on using tickets.