Opened 13 years ago

Closed 13 years ago

#1232 closed enhancement (worksforme)

Long running getAllInheritedAnnotations query

Reported by: base Owned by: Nicklas Nordborg
Priority: major Milestone: BASE 2.11
Component: core Version:
Keywords: experiment overview inherited annotations query Cc:

Description

The query that retrieves all inherited (directly and indirectly) annotations for an annotation set is not efficient. It results in long waiting time for experiment overview and experiment re-validation. The issue and a simple fix is described in more detail here http://www.mail-archive.com/basedb-users@lists.sourceforge.net/msg01650.html

Change History (7)

comment:1 Changed 13 years ago by Nicklas Nordborg

Milestone: BASE 2.11

comment:2 Changed 13 years ago by Nicklas Nordborg

Type: defectenhancement

comment:3 Changed 13 years ago by Martin Svensson

Owner: changed from everyone to Martin Svensson
Status: newassigned

comment:4 Changed 13 years ago by Nicklas Nordborg

Owner: changed from Martin Svensson to Nicklas Nordborg
Status: assignednew

comment:5 Changed 13 years ago by Nicklas Nordborg

Status: newassigned

comment:6 Changed 13 years ago by Nicklas Nordborg

I am not able to reproduce this on either PostgreSQL 8.3.6 or MySQL 5.0.67. I have tested with an experiment that has 128 annotated raw bioassays on both databases. In both cases the getAllInheritedAnnotations() query takes about 5-10 milliseconds to execute. There is an additional 5-10 milliseconds to return the resulting Annotation objects and then about 10-20 milliseconds to load/validate the actual annotation values. On averge each node requires about 30 milliseconds to fully load.

comment:7 Changed 13 years ago by Nicklas Nordborg

Resolution: worksforme
Status: assignedclosed
Note: See TracTickets for help on using tickets.