Opened 13 years ago

Closed 13 years ago

#1226 closed defect (fixed)

The "Share new files and subdirectories automatically" option causes ConnectionClosedException in Base1PluginExecuter

Reported by: Nicklas Nordborg Owned by: Nicklas Nordborg
Priority: major Milestone: BASE 2.9.2
Component: core Version:
Keywords: Cc:

Description

When running a BASE1 plug-in with the Base1PluginExecuter an output directory is a required parameter. If the selected directory has enabled the "Share new files and subdirectories automatically" option the plug-in crashes with the stacktrace below. The workaround is to disabled the "Share new files and subdirectories automatically" option.

net.sf.basedb.core.ConnectionClosedException: The connection has been closed.
at net.sf.basedb.core.DbControl.getItem(DbControl.java:731)
at net.sf.basedb.core.SharedItem.getItemKey(SharedItem.java:59)
at net.sf.basedb.core.ShareableUtil.copyPermissions(ShareableUtil.java:174)
at net.sf.basedb.core.File.getNew(File.java:103)
at net.sf.basedb.plugins.Base1PluginExecuter.importTempFiles(Base1PluginExecuter.java:1939)
at net.sf.basedb.plugins.Base1PluginExecuter.run(Base1PluginExecuter.java:659)
at net.sf.basedb.core.PluginExecutionRequest.invoke(PluginExecutionRequest.java:106)
at net.sf.basedb.core.InternalJobQueue$JobRunner.run(InternalJobQueue.java:504)
at java.lang.Thread.run(Thread.java:619)

NOTE! This bug is related to #1225. They have the same root cause (trying to use a directory after it's database connection has been closed) but needs a different fix.

Change History (2)

comment:1 Changed 13 years ago by Nicklas Nordborg

Owner: changed from everyone to Nicklas Nordborg
Status: newassigned

comment:2 Changed 13 years ago by Nicklas Nordborg

Resolution: fixed
Status: assignedclosed

(In [4714]) Fixes #1226: The "Share new files and subdirectories automatically" option causes ConnectionClosedException?? in Base1PluginExecuter

Note: See TracTickets for help on using tickets.