Opened 13 years ago

Closed 13 years ago

#1218 closed defect (duplicate)

Unexpected error viewing Project Summary in shared project

Reported by: base Owned by: everyone
Priority: major Milestone:
Component: web Version:
Keywords: Cc:

Description

Hi,

I have created a number of projects called 'development', 'evaluation', 'production', 'release' as a means of managing the process of release of data. My intention was to model each experiment in the development project, when it is complete share it with the evaluation project for checking, then share it with the production project, etc.

I have an admin user, which created a lot of the objects, and an end-user account which is a member of all of the projects.

My first experiment validates OK in the development project, and is shared with the evaluation project. I am pretty sure that I have also shared every component of the experiment too, but of course it is difficult to know. Both the admin user and the end-user can see the experiment in both projects.

When I go to the Summary of the experiment, and flip from the development to the evaluation project, the end-user gets this error for the left pane, and something very similar for the right (for the admin user everything is OK):

First, should I share the experiment at the end rather than at the beginning of this process, and will all the elements inherit the share if I do it this way?

Second, is there a problem using an admin user to create 'ordinary' objects such as experiments, etc?

jay.moore@…

Unexpected error

java.lang.NullPointerException? on page /base2/views/experiments/overview/tree.jsp Version BASE 2.9.0 (build #4667; schema #65) Web server Apache Tomcat/6.0.18 Database Server MySQL 5.0.45-log Database Dialect org.hibernate.dialect.MySQLInnoDBDialect JDBC Driver com.mysql.jdbc.Driver (version 5.1) Java runtime Java(TM) SE Runtime Environment (1.6.0_07-b06-153), Apple Inc. Operating system Mac OS X x86_64 10.5.5 Memory Total: 180.0 MB Free: 58.4 MB Max: 479.2 MB Browser Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_5_5; en-us) AppleWebKit?/525.18 (KHTML, like Gecko) Version/3.1.2 Safari/525.20.1 Error message Stack trace java.lang.NullPointerException? ...at net.sf.basedb.util.overview.ExperimentOverview?.addSample(ExperimentOverview?.java:1223) ...at net.sf.basedb.util.overview.ExperimentOverview?.addExtract(ExperimentOverview?.java:1137) ...at net.sf.basedb.util.overview.ExperimentOverview?.addLabeledExtract(ExperimentOverview?.java:1012) ...at net.sf.basedb.util.overview.ExperimentOverview?.addLabeledExtracts(ExperimentOverview?.java:934) ...at net.sf.basedb.util.overview.ExperimentOverview?.addHybridization(ExperimentOverview?.java:839) ...at net.sf.basedb.util.overview.ExperimentOverview?.addScan(ExperimentOverview?.java:805) ...at net.sf.basedb.util.overview.ExperimentOverview?.addRawBioAssay(ExperimentOverview?.java:654) ...at net.sf.basedb.util.overview.ExperimentOverview?.addRawBioAssays(ExperimentOverview?.java:629) ...at net.sf.basedb.util.overview.ExperimentOverview?.generateOverview(ExperimentOverview?.java:336) ...at net.sf.basedb.util.overview.ExperimentOverview?.<init>(ExperimentOverview?.java:276) ...at net.sf.basedb.util.overview.ExperimentOverview?.getOverview(ExperimentOverview?.java:206) ...at org.apache.jsp.views.experiments.overview.tree_jsp._jspService(tree_jsp.java:164) ...at org.apache.jasper.runtime.HttpJspBase?.service(HttpJspBase?.java:70) ...at javax.servlet.http.HttpServlet?.service(HttpServlet?.java:717) ...at org.apache.jasper.servlet.JspServletWrapper?.service(JspServletWrapper?.java:374) ...at org.apache.jasper.servlet.JspServlet?.serviceJspFile(JspServlet?.java:342) ...at org.apache.jasper.servlet.JspServlet?.service(JspServlet?.java:267) ...at javax.servlet.http.HttpServlet?.service(HttpServlet?.java:717) ...at org.apache.catalina.core.ApplicationFilterChain?.internalDoFilter(ApplicationFilterChain?.java:290) ...at org.apache.catalina.core.ApplicationFilterChain?.doFilter(ApplicationFilterChain?.java:206) ...at net.sf.basedb.clients.web.servlet.CharacterEncodingFilter?.doFilter(CharacterEncodingFilter?.java:70) ...at org.apache.catalina.core.ApplicationFilterChain?.internalDoFilter(ApplicationFilterChain?.java:235) ...at org.apache.catalina.core.ApplicationFilterChain?.doFilter(ApplicationFilterChain?.java:206) ...at org.apache.catalina.core.StandardWrapperValve?.invoke(StandardWrapperValve?.java:233) ...at org.apache.catalina.core.StandardContextValve?.invoke(StandardContextValve?.java:191) ...at org.apache.catalina.core.StandardHostValve?.invoke(StandardHostValve?.java:128) ...at org.apache.catalina.valves.ErrorReportValve?.invoke(ErrorReportValve?.java:102) ...at org.apache.catalina.core.StandardEngineValve?.invoke(StandardEngineValve?.java:109) ...at org.apache.catalina.connector.CoyoteAdapter?.service(CoyoteAdapter?.java:286) ...at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:845) ...at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.process(Http11Protocol.java:583) ...at org.apache.tomcat.util.net.JIoEndpoint$Worker.run(JIoEndpoint.java:447) ...at java.lang.Thread.run(Thread.java:637)

Change History (1)

comment:1 Changed 13 years ago by Nicklas Nordborg

Resolution: duplicate
Status: newclosed

Duplicate of #1217.

Note: See TracTickets for help on using tickets.