Opened 14 years ago

Closed 14 years ago

#1194 closed defect (fixed)

A missing raw data type breaks experiment and raw bioassay views

Reported by: base Owned by: Nicklas Nordborg
Priority: major Milestone: BASE 2.9.1
Component: web Version: 2.9
Keywords: sorting, filtering, experiments list view Cc:

Description

Sorting and Filtering in the Experiments List View is not working at all. The preset filters cannot be changed (nothing happens when one tries), and on choosing "clear filter" one gets logged out. I can also not change the visible columns, and when I click on a column header to sort by that column, nothing happens at all.

Versions: BASE 2.9 Linux (Centos 5) Java(TM) SE Runtime Environment (build 1.6.0_02-b05) Firefox 3.0.4

Submitted by: Micha Bayer (micha.bayer@…)

Change History (6)

comment:1 Changed 14 years ago by base

P.S.: I also just noticed that I cannot delete items from the Experiment list view, but I can open them and delete them individually from the detail view.

All of the above also happens in IE6, so it's probably not related to the browser.

comment:2 Changed 14 years ago by Nicklas Nordborg

Works fine when I try it. Can you check the log file for error messages?

comment:3 Changed 14 years ago by base

Sorry -- problem at this end. I checked the logs and the error results from an experiment owned by another user which was using a custom raw data type I created as an experiment at an earlier stage and which now does no longer exist. This threw the list view into a flat spin and logged any other user out that attempted to filter the experiments.

You can close this ticket -- it's obviously not a bug then. My Apologies.

comment:4 Changed 14 years ago by Nicklas Nordborg

Summary: Sorting and Filtering of Experiment list view brokenA missing raw data type breaks experiment and raw bioassay views

Ah... yes I think we have seen this before. I think BASE should be able to handle this a bit better. We can probably add some error handling just as we do when a user might not have permission to access a linked item. I am keeping this in BASE 2.9.1. The same problem will probably also appear in the raw bioassays list and in the single-item view pages.

comment:5 Changed 14 years ago by Nicklas Nordborg

Owner: changed from everyone to Nicklas Nordborg
Status: newassigned

comment:6 Changed 14 years ago by Nicklas Nordborg

Resolution: fixed
Status: assignedclosed

(In [4686]) Fixes #1194: A missing raw data type breaks experiment and raw bioassay views

Note: See TracTickets for help on using tickets.