Opened 13 years ago

Closed 12 years ago

#1128 closed enhancement (fixed)

Export of child items

Reported by: base Owned by: Martin Svensson
Priority: major Milestone: BASE 2.12
Component: web Version: 2.8.2
Keywords: Cc:

Description

Export of items does not allow selection of child items. I think that it would be an improvement to also be able to export these child items. If multiple child items are referenced, these could be separated with a comma. In this way one would be able to export the same table that is shown on the screen.

Change History (11)

comment:1 Changed 13 years ago by Nicklas Nordborg

The table exporter plug-in only supports exporting "simple" properties. This is a limitation in the implementation caused by the "generic" nature of the exporter. The details:

  1. The exporter is given a query and a list of columns.
  2. The exporter executes the query and uses internal meta-data to extract the requested columns.
  3. The "child" columns in the table as seen on the web interface is not part of the main query, but are separate queries that are executed once for every row in the query. These queries are not sent to the exporter since they not part of the "current state" information.

To solve this issue would require major changes in the way the tables are generated as well as in the exporter plug-in.

comment:2 Changed 13 years ago by Jari Häkkinen

Maybe we should create a special export that allows inclusion of child and/or parent items?

comment:3 Changed 12 years ago by Nicklas Nordborg

Milestone: BASE 2.12
Summary: Export of itemsExport of child items

See ticket #1272 for a possible way to solve this issue.

comment:4 Changed 12 years ago by Martin Svensson

Owner: changed from everyone to Martin Svensson
Status: newassigned

comment:5 Changed 12 years ago by Martin Svensson

Changeset [4895] belongs to this ticket.

comment:6 Changed 12 years ago by Martin Svensson

(In [4896]) References #1128 Undoing changeset [4895]

comment:7 Changed 12 years ago by Martin Svensson

(In [4899]) References #1128 Tested the dataloaders on extracts' children.

comment:8 Changed 12 years ago by Martin Svensson

(In [4900]) References #1128 Parents of extracts can now be exported with the SimpleExporter?.

comment:9 Changed 12 years ago by Martin Svensson

(In [4901]) References #1128 Updated list-pages and index-pages for the majority of items that have some kind of child or parent connections. Also extended the NameableFormatter? to handle null as a parameter value.

comment:10 Changed 12 years ago by Martin Svensson

(In [4906]) References #1128 More item-pages updated

comment:11 Changed 12 years ago by Martin Svensson

Resolution: fixed
Status: assignedclosed

(In [4907]) Fixes #1128 Export of child items

Note: See TracTickets for help on using tickets.